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Part One • Welcome to Search!

An introduction to Search 3.1.1

Search 3.1.1 is a state-of-the-art system for image cataloging, retrieval,

and manipulation. With a user interface designed specifically for the

professional production environment, Search’s speed, convenience, and

versatility are vital to the most efficient use of Apple®  Macintosh®-

based files.

With Search, you can create catalogs that serve as visual databases for

files from any format, location, and original application. Since the

catalogs contain references to the original files but not the original files

themselves, more than 100,000 records can be quickly cataloged and

searched. You can preview, copy, or move original files directly from

Search.

Search uses criteria that you establish to retrieve and display specific

records for your review and manipulation. Up to four levels of search

criteria can be specified based on file names, keywords, file types,

volumes, cataloged dates, modification dates, expiration dates, etc.

Records are displayed as thumbnails or as rows of record information.

Search allows multiple users to search multiple catalogs with original

files at multiple locations—simultaneously! Whether the catalogs are

located on your hard disk or in volumes on network servers, you can

search up to ten catalogs at once. To maintain catalog and original file

accuracy and availability in a multiple-user environment, access to

Search functions that can alter catalogs or original files can be

controlled by implementing password protection.

Search is easy to learn and use; its powerful collection of tools and

features were designed to interact in a clear, understandable way. A

basic operating knowledge of the Macintosh is necessary to operate

Search, so please familiarize yourself with terms such as clicking,

dragging, pull-down menus, and desktop before proceeding. Once you
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are in command of basic Macintosh operations, you will enjoy the full

benefit of Search’s intuitive interface.

Search documentation

This manual is a comprehensive guide to Search 3.1.1. Take a moment to

review the different sections and decide the best place to start.

• Part One: Welcome to Search!
Introduces you to Search 3.1.1 and lists new features, installation

procedures, and file placement during installation.

• Part Two: A Getting Started Tutorial
Contains a self-paced, step-by-step guide to Search basics.

• Part Three: Catalog Creation & Management
Describes how to create and maintain catalogs, set security

options, and work in multiple-user environments.

• Part Four: Catalog Searches
Explains how to define searches, search catalogs, and view

records in standard or thumbnail view.

• Part Five: Using Search Results
Explains how to use search results, including previewing and

manipulating original files. Also covered is how to use Search with

other programs, such as Multi-Ad Creator or QuarkXPress.

• Part Six: Reference
Explains each Search menu, menu item, and dialog box.

General conventions

• Lists which provide information, like this one, are bulleted (•).

• Lists which provide sequential steps in a procedure are 

numbered (1, 2,…).

• Single-step procedures are designated with this symbol: .

• Search functions that are automatically restricted in multiple-

user mode or that can be locked from users with security options

are designated with this symbol: .
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• System 7-specific features are designated with this symbol: ⑦.

•  Although QuickTime is not required when using Search 3.1.1, it 

is strongly recommended for optimum usage. Features requiring 

QuickTime availability are designated with this symbol: 

Keyboard conventions

Keyboard shortcuts are shown as -O, which means to hold down

the Command key while pressing the “O” key. Note that while the

“O” is capitalized, do not hold down the Shift key unless it’s

specifically requested. Other key abbreviations include:

Command key Shift key Return key ↵
Option key Control key

Some key terms

Original file or file –graphics or any other file type you specify

for cataloging. You don’t search the original files once they are

cataloged; you search the records that Search creates for them.

Through these records, Search provides ways to preview and

manipulate the original file for use in other programs.

Reference –a specification of the name, volume, and folder

location of an original file. A reference is part of a record. Search

copies or sends references of original files so that the original files

themselves do not have to be copied or sent.

Record –the collection of information that Search catalogs about

the original file. A record of an original file includes its reference,

thumbnail, file name, file type, location, size, and so forth.

Catalog –a visual database of original file records—not the original

files themselves. When you add files to a catalog, you are really

adding records of files to the catalog.

Recognizing vs. supporting a file type –If Search recognizes a
file type, it is able to catalog that file type and search by it. If

Search supports a file type, it is able to catalog it, search by it, and

create a thumbnail and provide a preview for it. Search recognizes

user-added file types but does not support them, with the exception



Search • User's Guide  11

of file types that can be converted by QuickTime importers into

QuickTime movies.

Installation

Hardware guidelines and recommendations

    Component        Minimum         Recommended    

Computer Macintosh Plus or SE Macintosh II or better

Available memory 1.5 MB 3 MB or more

Operating System System 6.0.3 System 7.1

QuickTime is also strongly recommended.

Note : Calculate available memory by subtracting the amount of memory
used by your system software from the amount of memory available
in your system.

Installing Search 3.1.1

As a precaution, make backup disks of the Search program disks before

you install and be sure to lock the backup disks to prevent accidental

erasure. Either the program disks or the backups can then be used to

install Search.

To install Search 3.1.1

1. Begin with your Macintosh turned on and at the Finder level.

Make sure no other application programs are running.

Turn off all virus-checking software. This can usually be done in

the software’s control panel in the System Folder. Refer to the

documentation of the virus-checking software for more details.
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2. Insert Search 3.1.1 Disk 1. Double-click on it, if necessary, to

view its contents:

3. Double-click on the Install icon. A box containing information

about Search appears.

4. Click Continue. The Search installation file is displayed.

Read this screen for important notes on the installation

procedure. Additional Search documentation may be included

here also. Once you’ve read the contents of the window, click

Continue to resume installation or click Cancel to quit. You can

also click Print to print the Read Me file. Page Setup and Print

dialog boxes are displayed so that you can make any printing

adjustments.
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Click Continue. The Registration dialog is displayed:

5. Enter the appropriate information into each field. Use the Tab

key to move from field to field. This customer profile is used to

keep you informed about updates and special upgrade offers.

Your serial number is located inside the front cover of this

manual, on your Search packaging, or on the disk

envelope.After you click Register, a directory dialog box is

displayed:
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6. Here, you can customize your Search installation or perform a

full installation. Please note the “Installation requires”

message, located below the gray line, which tells you how much

hard disk space you will need for the installed files.

If you select Full Install and click the Install button, you can

move on to Step 7. However, if you want to do a Custom

install—perhaps to save hard disk space—you can highlight the

specific resources you want to install. Hold down the Shift key

or Command key to select more than one option.

When a single option is selected, information about it is displayed

below the scrolling list. This information tells you the purpose of

the selected option and can help you determine whether or not its

installation is necessary for your use of Search. In addition, the

“Installation requires” message changes with each selection,

keeping you posted on how much hard disk space your selected

options will require once installed.

After you have made your selections, click Install to continue

the installation process. You can also click Quit to cancel the

installation process.
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7. A message may be displayed, informing you that your

Macintosh needs to be restarted after installation is complete.

This message is displayed if any Extensions, such as

QuickTime, are to be installed. Click Yes to continue with

installation, click No to cancel installation.

8. When you continue with the installation, you are asked to select

a destination for your Search 3.1.1 folder.

Using the Macintosh Hierarchical Filing System (HFS), select a

destination on your system for the Search 3.1.1 folder. For more

information on the HFS system, please consult your Macintosh

documentation. Click Save to proceed with installation.

9. The installer begins to install Search resources.

The installer will eject Disk 1 and ask for Disk 2 and so on.

Watch the on-screen instructions for guidance.
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After the Installer is finished, the final disk is ejected and the

following dialog box is displayed:

If this is your first time running the Installer, insert your

Search registration disk into your computer’s floppy drive.

When it is ejected, place the disk in the supplied mailer and

send it to us.

If you have already mailed in your registration disk, click

Cancel. Your version of Search will still be registered.

10. You may be asked to reinsert Disk 1. Please do so. The following

message is then displayed if any Extensions were installed:

11. Click Restart.

If you need help with this installation, please contact our

Customer Services department. Before doing so, however,

please familiarize yourself with the installation process so that

we can help you locate the problem.



Search • User's Guide  17

File placement during installation

During installation, the installer placed the Search application and its

support files into specific folders. The following is a list of those files

and their location after a full installation is complete:

In the Search 3.1.1 Install folder :

Search 3.1.1 folder

folder contains
Search 3.1.1

Search 3.1.1 Help (requires System 7)
Search 3.1.1 Thesaurus

LockServer utility

Get Search utility

Search 3.1.1 AppleScript Demo (installed only if using System 7)
Tutorial Art folder

folder contains
Realistic Art folder

Cartoon Art folder

In the System folder
QuickTime (in “Extensions” under System 7, 

requires 32-bit QuickDraw color)

Converting catalogs from Search 3.1.1 or Aldus Fetch™ 1.0

Catalogs created in Multi-Ad Search 1.0 or Aldus Fetch 1.0 can easily

be converted to Search 3.1.1 catalogs. During the conversion process,

Search creates a copy of the original catalog and converts the copy to

Search 3.1.1, leaving your original catalog intact in its original format.

Note: Because Search leaves your original catalog intact, this conversion
process may take extra time and requires that you have enough
extra disk space available for the copy. The process may take as
long as building the original catalog did.

To convert a Search 3.1.1 catalog to Search 3.1.1
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1. With the Search 3.1.1 application running, choose Open from

the File menu.

2. In the directory dialog box, double-click on the catalog you want

to convert or highlight the catalog’s name and click Open.

3. In the subsequent directory dialog box, specify any name or

location changes for the converted catalog, then click Save.

Search will automatically make a new, converted catalog for you.

To convert an Aldus Fetch 1.0 catalog to Search 3.1.1

Note: Search only converts Fetch 1.0 catalogs; it will not convert
catalogs from any later versions.

1. Make sure the original Fetch catalog is updated, purged, and

current.

2. With the Search application running, choose Open from

Search’s File menu.

3. In the dialog box, double-click on the catalog you want to

convert or highlight the catalog’s name and click Open.

4. In the subsequent directory dialog box, specify any name or

location changes for the converted catalog, then click Save.

5. Do an update/purge in Search by choosing Update/Purge

Catalog from the Admin menu.

Converting catalogs from Search 2.0

Catalogs created in Search 2.0 can also be converted to Search

3.1.1 catalogs. The Search 2.0 catalog itself is converted; a copy

of the catalog is not  created and then coverted. This means that

once the Search 2.0 catalog is converted to Sile-o-Mat 1.0, you

are no longer able to open the catalog with Search 2.0. Because

no copy is made, this is a quicker conversion process than when

you convert Search 1.0 or Aldus Fetch 1.0 catalogs.
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Warning: When converting Search 2.0 catalogs, Search 3.1.1 does not
make a copy of the catalog to convert. It converts the original
catalog.

To convert a Search 2.0 catalog to Search 3.1.1

1. With the Search 3.1.1 application running, choose Open from

the File menu.

2. In the directory dialog box, double-click on the catalog you want

to convert or highlight the catalog’s name and click Open.

3. In the subsequent dialog box, specify whether you want to

convert the catalog from Search 2.0 to Search 3.1.1 or if you

want to leave the catalog in Search 2.0 and open it in read-only

mode. If you click Yes to convert the catalog,  you will no
longer be able to access the catalog with Search 2.0. If you

click No, the Search 2.0 catalog will remain a Search 2.0 catalog

and be opened in Search 3.1.1 in read-only mode. You can also

click Cancel to cancel this dialog.
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Part Two • A Getting Started Tutorial

Overview

The following tutorial is a self-paced guide for those who are new to

Search. It is truly a “getting started” tutorial; you get experience with

basic Search functions like building and searching catalogs and

previewing original files.

Before you begin, first make sure that you are familiar with basic

Macintosh operations and terminology, such as clicking, dragging,

desktop, and Finder level. Refer to your Macintosh manual if you need

assistance. Also, please review Part One of this manual; it contains

listings of key Search terms and documentation conventions that are

used here.

Second, determine which operating system version your machine is

using: System 6 or System 7. To do this, choose About this Macintosh

from the Apple menu while at the Finder level. Since System 7 provides

additional methods for procedures like creating catalogs or opening

catalogs, instructions in this tutorial are sometimes given for both

systems. By knowing your operating system version, you’ll know which

instructions you can try. System 7-specific instructions will be marked

with the following symbol: ⑦

Third, if you have not installed Search 3.1.1, please do so now. For a

detailed explanation of the installation process, please refer to

“Installation,” in Part One of this user’s guide. The original files you

catalog in this tutorial are placed in the Search 3.1.1 Install folder

during the installation process in a folder called “Tutorial Art.”

Finally, make sure your workstation is set to single-user mode so you

have full access to all Search functions.

To make sure your workstation is in single-user mode

1. Start Search by double-clicking on the Search icon.
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To tell if Search is running and if it is the active program, look

for the Search menu bar at the top of the screen. It includes the

following menus:  (Apple), File, Edit, Search, Window, and

Admin. Some of the menu names may be dimmed.

2. Highlight Preferences in the Edit menu and choose General

from the Preferences submenu.

3. From the Database mode options, click Single user if it is not

already selected.

Note : While in the General preferences dialog box, also make sure that
the On Startup preference is set at “Do nothing.”

4. Click OK, or click Cancel if you didn’t make any changes.

5. Restart Search when you switch from multiple-user to single-

user mode. However , for this tutorial, quit Search now

whether or not you changed modes and wait to restart it in the

following section.

Building catalogs

In this section, you’ll create two catalogs, Realistic Animals and Cartoon

Animals. Just a reminder—the original files you will catalog here were

placed in a folder called “Tutorial Art” in Search 3.1.1 Install folder

during the Search installation process.

Building Catalog # 1: Realistic Animals

1. Start Search by double-clicking on the Search icon at the

Finder, or desktop, level.

Note: At startup, you may be asked to locate the thesaurus. It is placed
in the Search 3.1.1 folder, which is contained in the Search 3.1.1
Install folder, during installation.

The Search startup screen will be displayed and then removed

from the screen. Then, the Search menu bar should appear at

the top of the screen. It includes the following menus:  (Apple),

File, Edit, Search, Window, and Admin.
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2. Choose New from the File menu, or press -N.

3. In the directory dialog box, enter the new catalog’s name:

Realistic Animals .

4. Specify the location for the new catalog as the Search 3.1.1

Folder.

5. Click Save. Search creates the Realistic Animals catalog and

displays it on screen.

6. Under the Edit menu, choose Keywords from the Preferences

submenu. Make sure the “Save Filenames as Keywords” option

and the “Save Folder Names as Keywords” option are selected.

Because of these selections, the folder names and filenames of

the original files to be cataloged will be listed as keywords in

the original file’s record once cataloging is complete. Click OK.

7. Choose Add Files from the Admin menu, or press - -A.

Folder
button

Summary of options selected 
in Thumbnail preferences

List 
box

8. Review the settings in the Add Files dialog box. Choose the

following options:
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•File Types: Press -A to select all files in the 

scrolling list. You can also press -Z to 

deselect all file types listed. To select or 

deselect individual files, click once on 

them.

•Update Method: Choose “Add Only” from the pop-up menu.

•Make sure the “Include All Subfolders” checkbox is 

  selected.

The information listed to the right of the File types list is a

summary of the options selected in Thumbnail preferences,

found under Preferences in the Edit menu. For the purpose of

this tutorial—and in most other cases—the default settings will

work just fine. For an explanation of these options, please refer

to the Reference section of this manual.

9. Locate the folder called Realistic Art in the Tutorial Art folder

within the Search 3.1.1 Install folder. Highlight the Realistic

Art folder and click Open.

The Folder button becomes the Realistic Art button. (Please

refer to the “Add Files dialog box” figure on the previous page if

you have questions.)

10. Click the Realistic Art button.

Records of the original files in Realistic Art are entered into the

catalog Realistic Animals. Since the “Include All Subfolders”

option was selected, all files in all folders within the Realistic

Art folder will be cataloged. Remember that with Search,

records of the original files and not the original files themselves

are cataloged, saving time and space.

When cataloging is complete, Search then displays a report of

the activities, including the number of records added to the

catalog.

11. Click OK to continue.

The records are now displayed in the catalog window. You can

view the catalog records in standard view or thumbnail view—
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just choose one view or the other from the Window menu. Take

a moment to browse the different records in both thumbnail and

standard view.

Building Catalog # 2: Cartoon Animals

Search 3.1.1 has the ability to search multiple catalogs simultaneously,

so now you’ll create another catalog to help demonstrate this feature. If
you are running System 6, simply follow the same procedure used to
build the first catalog, only use the folder named Cartoon Art to create
the catalog Cartoon Animals. Then, continue on to the “Opening

Catalogs” section of this tutorial. If you are running System 7, however,

use the following method to build your second catalog.

⑦ For the purpose of this set of instructions, you need to quit Search 

after building the first catalog. Please do so now.

1. Begin at the Finder level, with Search not running. View the

contents of your Search 3.1.1 Install folder.

2. Drag the icon of the Cartoon Art folder, which is located in the

Tutorial Art folder, onto the Search icon, located in the Search

3.1.1 folder, until both are highlighted, then release. Note : you

may need to double-click on the Tutorial Art and Search 3.1.1

folders in order to see the necessary icons.

This is called “drag and drop” file adding. Search will start up

and after a moment display this dialog:

3. Click New to specify that Search is to add the files to a new

catalog and not to an already existing catalog.

4. In the directory dialog box, enter Cartoon Animals  for the

name of the catalog and place it in your Search 3.1.1 Folder.
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5. Click Save.

Search automatically creates the new catalog and adds the file records

to it. A report of the activities is displayed. Click OK.

Since you don’t get a chance to review the settings in the Add files

dialog box when using this System 7 procedure, Search automatically

uses the settings from the previous Add Files activity.

Additional cataloging features and issues are covered in
“Part Three • Catalog Creation & Management.”

Opening catalogs

Begin this section by quitting Search and returning to the desktop. To

quit Search, choose Quit from the File menu or press -Q. Then, use

the following procedures to open both catalogs; the second set of

instructions is for System 7 only.

Opening Realistic Animals and Cartoon Animals separately

1. At the Finder level, double-click on the icon of the Realistic

Animals catalog. It should be located in your Search 3.1.1

folder.

Search opens and displays the catalog. Now, open the second

catalog from within Search.

2. Choose Open from the File menu, or press -O.

3. In the directory dialog box, select the Cartoon Animals catalog

and click Open.

With both catalogs open, you are ready to go on to the “Searching

catalogs” section of this tutorial. However, if you are running System 7

and would like to try the following procedure to open catalogs

simultaneously, quit Search and return to the Finder level.

⑦ Opening Realistic Animals and Cartoon Animals simultaneously

1. Begin at the Finder level, with the Search application not
running.

2. Select the Realistic Animals catalog icon.
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3. Hold down the Shift key while you also select the Cartoon

Animals catalog icon.

4. Drag both icons onto the Search 3.1.1 icon until all are

highlighted, then release. Search opens both catalogs.

Note : To open both catalogs simultaneously in System 6, you can select
both catalog icons and then choose Open from the File menu, or
double-click on one when both are highlighted.

Searching catalogs

You now have two open catalogs from which to work. If you cannot see

both catalog windows, one may be directly on top of the other. Look

under the Window menu to see a listing of open catalogs. In the

Window menu, you can select which catalog you want to be the

frontmost catalog.

If the number of records in a catalog is small enough or if the range of

its contents is limited—much like the tutorial catalogs you’ve created

here—you can browse through the catalog to find the exact record for

which you’re looking. Generally, however, this is not the case. Catalogs

created in Search can contain 100,000-plus records.

For instance, either of the catalogs you created could contain thousands

of animal images—from cows to camels to cats, from ducks to dolphins

to dogs—from which you need to locate just a few records which meet

specific criteria. Instead of browsing through thousands of thumbnails

or rows of text information, you can request specific records by using a

search definition you create. That’s the power of Search!

For example, let’s say you want to find some dog art that could be used

in an ad for the local humane society. After your catalogs of animal art

are made, you want to search both catalogs for any dog art available. In

addition, let’s say you need to narrow the art to EPS or TIFF files

modified after 1/11/1990.

Searching the catalogs

1. With the catalogs open, choose Find from the Search menu, or

press -F.
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2. Define your search in the Find Files dialog box with the criteria

listed below. The four rows of search descriptions allow you to

make your criteria as general or as specific as you’d like.

• Review the various options in the pop-up menus.

• Click the checkbox beside each description row to activate that 

row as you fill in the following search criteria:

When you select the keyword list option, the following dialog

automatically appears:

Here, you can broaden your keyword search by adding the

synonyms of a specific keyword to the search. Simply type in

the keyword—in this case, “dog”—click Add, and click on the

Synonyms button. The synonyms for “dog” are added to the

keyword list. Click OK to officially add them to your search and

to return to the Find Files dialog box.

3. Back in the Find Files dialog box, select the “Search all open

catalogs” option so that both catalogs are searched. Otherwise,

only the active, or frontmost, catalog is searched.

4. When your search criteria are set, click Find.
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Search retrieves the requested records and displays them in

each catalog window, temporarily replacing the records of the

entire catalog. Close the Find Files dialog box or click once on

the catalog window you wish to view to move it to the front, or

choose the catalog’s name from the Window menu. In each

catalog, only the retrieved dog and puppy records should be

displayed.

5. View the Realistic Animals catalog in thumbnail view. Make

this catalog the frontmost catalog by choosing it from the

Window menu. Then, choose Use Thumbnail View from the

Window menu. At the top of the catalog window, note the boxes

containing file information, descriptions, and keywords; the

information in these boxes is that of the selected thumbnail.

6. Choose Use Standard View from the Window menu. The found

records are now displayed in rows of textual information, with

the thumbnail of each record appearing at the top of the view

window along with the record’s descriptions and keywords.

7. Sort the record rows by file name by clicking on the “file name”

heading.

Note : Hold down the Command key as you select records to select more
than one record row or thumbnail. Hold down the Shift key to
select a range of record rows or thumbnails.

Additional searching and viewing features are covered
in “Part Four • Catalog Searches.”

Editing keywords

Editing keywords and descriptions is one of the ways that you can

customize catalogs. In Search 3.1.1, you can even edit keywords across

multiple files.

Editing a keyword

1. View your Realistic Animals catalog window in Thumbnail

view.  It should still contain the results of your search. If it does

not, just redo the Search described above.
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2. Select the thumbnail of the Basset Puppy and Dog 1. Hold down

the Command key as you select the thumbnails to get both of

them selected.

3. Choose Common Keywords from the Edit menu, or press -Y.

4. Enter “canine”  in the Name field and click Add.

5. Click the Synonyms button to add the synonyms of the word

“canine” to the common keywords list.

6. Click OK.

Search adds the keyword “canine” and its synonyms to the

keywords lists in both the Basset Puppy and the Dog 1 records.

Note that keywords you add are in plain text; those locked by

the manufacturer are italicized.

Additional catalog editing features and issues are covered
in “Part Three • Catalog Creation & Management.”

Using search results

The power of Search is in its ability to catalog and search the records of

thousands of original files and its ability to use those records to

manipulate the original files themselves. Through their records, you

can preview, copy, move, edit, and delete original files, as well as send

original file references to other documents—even documents being
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created by other people at other workstations. To conclude this tutorial,

we will cover some of these features.

Previewing an original file

1. Make sure your Realistic Art catalog is in the frontmost window

and that you are viewing it in thumbnail view by choosing Use

Thumbnail View from the Window menu.

2. Select the Basset Puppy thumbnail. To get its preview, choose

Show Preview from the File menu or double-click on the

thumbnail.

3. Use the pop-up menu in the lower left corner of the Preview

window to increase the preview’s size to 200%, or whatever size

you’d like to work with. You can also use the Zoom In and Zoom

Out icons that are next to the pop-up menu.

4. Note that when you move the arrow into the preview area it

becomes a crosshair. Hold down on the mouse and drag the

crosshair to select a portion of the preview and release. You
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could now copy and paste this section into another document as

a PICT graphic.

5. Click anywhere to deselect the portion of the preview and close

the Preview window by pressing -W.

6. With the Basset Puppy thumbnail still selected, choose File Info

from the File menu or press -I.

The File Info window is displayed, and it contains information about

the original file, like location, size, keywords, descriptions, pathname

and so forth. Close the File Info window by clicking in the Close box in

the upper left corner or by pressing -W.

Note : You can have more than one preview and/or File Info window
open at a time. Simply select the records—holding down the
Shift key or Command key to select more than one—and choose
Show Previews or File Info from the Edit menu.

When you have found an original file to use, you can either copy or send

original file references to other programs and documents.

Copying references to another program

1. View your Cartoon Animals catalog in standard list view. To

make Cartoon Animals the frontmost catalog, click once on its

window or choose its name from the Window menu.

2. Select the “Dog in Innertube” and “Dog w/ Wagging Tail” record

rows. Remember to hold down the Command key to select more

than one record.

3. Hold down the Option key and choose Copy Reference from the

Edit menu. The references are now copied to the Clipboard.

4. View the Clipboard by choosing Show Clipboard from the

Window menu.

The contents of the Clipboard are now ready to be placed into a

receiving document. This is done in different ways in different

application programs, so you’ll want to refer to the

documentation of the receiving application for specific
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instructions. In QuarkXPress®, for example, you would choose

the Get Search command in the Utilities menu to place the

copied reference. Please continue with the following Multi-Ad

Creator example if you have the program.

5. Start Creator. If memory limitations prevent you from running

Search and Creator at the same time, you can quit Search and

start Creator without losing the contents of the Clipboard.

6. In a Creator ad, choose Place from the File menu.

7. In the subsequent dialog box, click “Add Search items to files

list.” The original file references you copied to the Clipboard are

now added to the Creator Files palette.

Additional information on using search results
can be found in “Part Five • Using Search Results.”

Now that you have been introduced to the basic features and functions

of Search, please refer to other sections of this manual for a much more

in-depth look at the program.
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Part Three • Catalog Creation & Management

Overview

Catalog management in Search 3.1.1 is designed with speed and

accuracy in mind. By cataloging only records of original files and not

the original files themselves, Search minimizes time spent cataloging or

searching. With its update, import, and purge commands, Search

provides an efficient interface for keeping original files, catalogs, and

records accurate and up to date.

This section will explain the following functions and features:

• creating new catalogs

• adding files to catalogs

• setting catalog add/update options

• viewing catalogs and catalog information

• setting security options

• editing keywords and descriptions

• deleting records

• updating and purging catalogs

• importing catalogs

You need to have full access to Search functions to use most of the

features covered in this section. If a command or option is dimmed in a

menu or dialog box, access may be locked through security settings or

your workstation may be set to multiple-user mode.

If multiple-user mode is the database mode selected in General

preferences, most features that can alter catalogs or original files are

restricted. However, you can gain access to them by switching to single-

user mode—unless security options have been set. See your catalog

administrator if security options have made Search functions
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unavailable to you. For additional details about multiple-user

limitations, please see “Multiple-user issues” at the end of this section.

Features and functions that can be locked from users are marked with

a “ ” symbol.

Creating a new catalog

Catalogs created in Search can contain thousands of records, depending

on the amount of memory available for catalog creation, storage, and use.

To create a new catalog at the Finder level

1. Start Search, then choose New from the File menu.

2. In the directory dialog box, designate a name and location for

the new catalog.

3. Click Save.

Search opens the empty catalog.

4. Choose Add Files from the Admin menu to add items to the

catalog. Please see “Adding and updating catalog records” on

page 29 for details.

⑦ To create a new catalog at the Finder level

1. At the Finder level, with Search not running, select the icons of

files, volumes, or folders to be added to a new catalog.

2. Drag the icons over the Search icon until all are highlighted,

then release. Search starts up and displays the following

dialog box:

3. Choose New.



Search • User's Guide  35

4. In the subsequent directory dialog box, specify a name and

location for the new catalog.

5. Click Save.
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Adding and updating catalog records

When you add files to a Search catalog, you are really adding records

of those files, not the files themselves. This allows you to catalog more

files and search through them faster. Although you can have up to ten

catalogs open at once, Search only adds files to the frontmost catalog.

To add files to a catalog

1. Start Search and create or open a catalog. If you are already

working in Search, make sure the catalog you want to add files

to is the active, or frontmost, window.

2. Set preferences—Thumbnail, Keyword, QuickTime, and File

exclusions—that affect cataloging or updating. The options

chosen in Thumbnail preferences are summarized in the lower

right area of the Add Files dialog box.

A brief look at setting these preferences is provided in “In detail:

setting catalog add/update options” beginning on page 33. Refer to the

Reference section of this manual for more detailed information.

3. Choose Add Files from the Admin menu, or press -- A. The

following dialog box is displayed:
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Folder
button

Summary of options selected 
in Thumbnail preferences

List 
box

4. In the list of file types, make sure the file types to be cataloged

or updated are selected with a check ( ). Click once on a file

type to select or deselect it. Select All ( -A) and Select None

( -Z) keyboard shortcuts can be used to quickly select or

deselect all available file types.

5. From the pop-up menu, select the update method. An

explanation of the options available is provided in “In detail:

setting catalog add/update options” beginning on page 33.

6. In the List box, locate and specify the files, folders, and/or

volumes to add to the catalog.

To add/update a single Select the file in the list box and click Open.

file Or, double-click on the file in the list box.

To add/update all files  Make sure the folder or volume name in a 

folder appears at the top of the list box—its 

name will then appear in the Folder button. 

Click the Folder button.
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To add/update all files  Make sure the folder or volume name appears 

and subfoldersat the top of the list box—its 

volume name will then appear in the Folder 

button. Then, select the “Include all subfolders”

option and click the Folder button.

⑦ To add/update all files Click the Desktop button. All files available 

and folders on  a on all volumes available are

added if desktop “Include all subfolders” is 

selected.

A status box is displayed as Search adds files. To cancel the

adding or updating process, press -period. Search will cancel

the process immediately, even if it is in the middle of cataloging

a graphic.

7. When cataloging is complete, Search displays a report box

which lets you know the number of files that were added and/or

updated.

Note: If Search could not create a thumbnail for a particular file, it is
reported as an “error” even though it has been cataloged properly.
The thumbnails for files like this—usually user-defined file types
added to the file types list in File Types preferences—contain their
program icon and pathname. Their keywords list will contain the
keyword “error.”

In detail: setting catalog add/update options

Options set in Preferences dialog boxes

Preferences settings that affect cataloging and updating must be set

before opening the Add Files dialog box.

File types

The list of file types that Search can catalog and search by is edited in

the File types preferences. Please note that while Search recognizes

(can catalog and browse through) user-added file types, it does not
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support (catalog, browse, preview and provide thumbnails for) them.

For a complete list of Search’s built-in file types and whether they are

supported or recognized, please see page 127 in the Reference section of

this manual.

To add a new file type for cataloging and searching

1. Choose File Types from the Preferences submenu under the

Edit menu. The following dialog box is displayed:

File type 

field

File type

description field

2. Enter a four-character file type and its description in the proper

fields. The description can be up to 22 characters long.

OR, if you are not sure which file type or description to enter:

Click Find a file. A directory dialog box is displayed. In the

directory dialog box, highlight the file type you want to add and

click Open.

Search automatically returns to the File types preferences

dialog box and enters the type and description in the

appropriate fields.
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3. Click Add. Or, if you have selected the list of file types by

clicking once on it, you can press -A. If the file types list is not

selected, pressing -A will select all text in the file type and file

type description fields.

4. Click OK to exit the dialog box and save changes.

To delete a file type

1. Choose File Types from the Preferences submenu under the

Edit menu.

2. In the File types preferences dialog box, highlight the file type

to be deleted.

3. Click Delete, or press -D.

4. Click OK to exit the dialog box and save changes.

To replace a file type

1. Choose File Types from the Preferences submenu under the

Edit menu.

2. In the File types preferences dialog box, enter the type and

description of the new file type, then highlight the file type to be

replaced.

3. Click Replace, or press -R.

4. Click OK to exit the dialog box and save changes.

Note: File types in italics are built into the Search application. They
are locked and cannot be deleted or replaced. File types that
users add are in plain text and can be deleted or replaced.

Application names

To add an application name

Choosing Application names from the Preferences submenu brings up a

dialog in which you can add applications to the list that Search already

recognizes. These applications are then used in the file information
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boxes in Standard or Thumbnail view and in the File Info window to

identify what application created a given original file.

1. Choose Application Names from the Preferences submenu

under the Edit menu.  The following dialog box is displayed:

Application 

type field

Application

description field

2. Enter a four-character application type and its description in

the proper fields.

OR, if you are not sure what the application type and  

description should be:

Click Find a file. In the directory dialog box, highlight the

application to add and click Open.

Search automatically returns to the previous dialog box and

enters the application type and description in the appropriate

fields.

3. Click Add. Or, if you have seleted the list of applications by

clicking once on it, you can press -A. If the applications list is

not selected, pressing -A will select all text in the application

type and application description fields.
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4. Click OK to exit the dialog box and save changes.

To delete an application name

1. Choose Application Names from the Preferences submenu

under the Edit menu.

2. In the Application Names dialog box, highlight the application

to be deleted.

3. Click Delete, or press -D.

4. Click OK to exit the dialog box and save changes.

To replace an application name

1. Choose Application Names from the Preferences submenu

under the Edit menu.

2. In the Application Names dialog box, enter the type and

description of the new application, then highlight the

application to be replaced.

3. Click Replace, or press -R.

4. Click OK to exit the dialog box and save changes.

Note: Applications in italics are built into the Search application.
They are locked and cannot be deleted or replaced. Applications
that users add are in plain text and can be deleted or replaced.

Find unknowns

Sometimes an application type may be listed as “Unknown” in the

Applications list. This means that Search has not yet identified what

application was used to create the cataloged files that contain the four-

character application type.

To find unknown file creators

In the Application Names dialog box, click Find unknowns.
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Search looks through all currently mounted applications to

identify and list the specific application that belongs with the

four-letter code. Once located, Search replaces “Unknown” with

the appropriate application description. This description is now

used in the File Info window and the File Information box to

identify file creators.

Adding an application vs. adding a file type

Applications and file types are added for different reasons. Added

applications are used only to identify what application created a given

file. Once the application is added, Search will label it as the “File

creator” of its given files in the File Info window or in the File

information box in thumbnail view. In this way, users are informed of

which program they need access to in order to edit each original file.

File types affect what kinds of files Search recognizes and, therefore,

can catalog and search by. Once a file type is added, it becomes an

option to add by in the Add Files command and an option to search by

in the Find command. Keep in mind, however, that Search does not

support user-added file types, except those that can be converted into

QuickTime movies by QuickTime importers.

Thumbnails of user-defined file types contain the file’s program icon

and its pathname. These file types cannot be previewed.
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QuickTime importing

Search uses QuickTime importing to convert file types it normally

would not support into QuickTime movies, a file type it does support.

To turn QuickTime importing on or off

1. Choose QuickTime Importing from the Preferences submenu

under the Edit menu. The following dialog box is displayed:

2. Select or deselect the “Do QuickTime importing” option.

3. To preview or create a thumbnail for the file types listed in this

dialog, QuickTime movies must be created in memory or as movie

files. Specify your preference in the Import method pop-up menu.

The default setting, “Prefer not to create movie files,” causes movies

to be created in memory whenever possible. Please refer to the

Reference section of this manual for more specific information on

these options.

4. Click the “Choose movie file location” button and specify the

location for any movie files created.
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5. If you want movie files to be deleted after viewing a preview or

File Info window, select the “Delete movie files after use” option.

6. Click OK to save changes, or click Cancel to exit the dialog

without saving changes.

 File Exclusions

If there are specific files you do not want added to or updated in your

catalogs, enter their file names in the File exclusions list.

To exclude files from cataloging or updating

1. Choose File Exclusions from the Preferences submenu under

the Edit menu. The following dialog box is displayed:

File
exclusions
list

2. Enter the name of the file into the text field below the File

exclusions list.

3. Click Add. Please note that you can edit file names already in

the list by using the Delete or Replace buttons.

4. Select the “Use Exclusions File” checkbox when you want Search to

exclude the files in the list when adding to or updating a catalog.

5. Select the “Automatically Add Exclusions” option to have Search

track and identify any files that cause cataloging problems. When
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you restart after a crash, Search will ask if you want to add the

corrupt file that caused the crash to the File exclusions list.

While this option slows down cataloging, it also saves you from

having to hunt down a corrupt file that’s causing problems.

6. Click OK to accept changes and exit the dialog box.

Note: To exclude an entire file type, you would deselect that file type in
the Add Files dialog box.

Keywords

To set Keywords preferences

1. Choose Keywords from the Preferences submenu under the Edit

menu to display the following dialog box:

2. With the “Sort keywords” option, specify how you want the

keywords displayed in the Keywords box in Thumbnail or

Standard view—alphabetically or by frequency.

3. To include the file name of each file as a keyword in its catalog

record, select the “Save Filenames as Keywords” option.

4. To include the name of the folder containing each file as a

keyword, select the “Save Folder Names as Keywords” option.

5. If a record’s description contains important words you want

included in the record’s keyword list, select the “Get Keywords

from Descriptions” option.
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When using this option, you can tell Search to skip words such as

“a” or “the” by adding them to the Keyword Exclusions list. In this

way, you prevent meaningless words in descriptions from

crowding the keywords list.

6. Click OK to save changes and exit the dialog.

Thumbnails

To set thumbnail preferences

1. Choose Thumbnail from the Preferences submenu under the

Edit menu to display the following dialog box:

2. Click the checkbox next to “Dither Black & White Thumbnails”

if you want Search to use dot patterns to simulate levels of gray

in black-and-white thumbnails.

3. Choose a thumbnail bit-depth level from the Thumbnail types

pop-up menu. This is the depth the thumbnails will be created

and stored at.

You can select any combination of 1-bit, 8-bit, 16-bit, and 32-bit

thumbnails. “Best depth,” the default setting, automatically

catalogs the best possible thumbnail. For more specific

information, please see page 134 in the Reference section.

4. Click the Options button to select a compression method. The

default settings—JPEG, High Quality and Best Depth—will

work best in most cases.
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Note: Unless you are very familiar with QuickTime compression
methods and understand each method’s benefits and limitations,
you will find it best to use the default settings.

5. Within each compression method, more than one type of

compressor/decompressor may be available. Specify which type

should be used in the Codec pop-up menu. The default selection,

“Any,” chooses arbitrarily from compressor/decompressor types

available. For more specific information on options available,

please see pages 135 in the Reference section.

6. Click OK to save changes and close the dialog box.

Options set in the Add files dialog box

Selecting file types
In the File types scrolling list, select the file types to be added or

updated. For a complete listing of file types that are built into Search

3.1.1 and are automatically available for cataloging, please see page

127 in the References section of this manual.

File types selected for cataloging or updating are designated with a check

( ).  Click once on a file type to select or deselect it. Select All ( -A) and

Select None ( -Z) keyboard shortcuts can be used to quickly select or

deselect all available file types.

If a file type you’d like to catalog is not listed, you can add the file type in

the File Types preferences dialog box. That file type then appears here in

plain text. Locked file types—those built into the Search program—

appear in italics and cannot be edited.

While Search can catalogs and search for user-defined file types, it does

not support them, i.e. create a thumbnail or display a preview, unless

those file types can be imported by QuickTime.
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Selecting the update method
To add to or update a Search catalog, make sure it is the active catalog.

The options in this pop-up menu are as follows:

• Add Only Records of new original files—files not 

in the catalog—are added.

• Add & Update Records of new original files are added; records 

from changed original files—files changed since 

being added to the catalog—are updated.

• Update Only Records of changed original files are updated. 

No new files are added.

• Force Update Records of original files are updated even if the 

files don’t appear to have been changed.

Viewing catalog information

General information about the entire catalog is available in the Catalog

Info window. You can view this window and print its contents.

Note: For details on viewing catalog records, please refer to “Viewing
search results” in Part Four.

To display the Catalog Info window

With a catalog open, choose Catalog Info from the File menu.
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To print the contents of a Catalog Info window

While viewing the Catalog Info window, choose Print from the

File menu.

To copy the contents of a Catalog Info window to the Clipboard

While viewing the Catalog Info window, choose Copy from the

Edit menu.

Setting security options

With Search’s flexible security options, access to catalogs and original

files doesn’t have to be “all or nothing”; different levels of accessibility

can be set. In addition, security options can be customized for each

catalog.

Catalog administrators use security options to limit single-user access

to the Search functions that can permanently alter catalogs or original

files. In multiple-user mode, many of these functions are automatically

unavailable, but since any user can access a catalog in single-user
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mode—as long as no one else is using the catalog—the security options

become a backup for maintaining that catalog’s accuracy.

To set security options

1. Open the catalog.

Make sure the catalog you want to add security options to is the

active catalog.

2. Choose Security Options from the Admin menu. The following

dialog box is displayed:

3. Select the commands that will remain available to users while

the password is in effect.

4. Enter the password and click OK.

5. Search then asks you to verify the password. Enter the

password and click OK.

6. Close and reopen the catalog to put the security options into

effect. The Password command replaces the Security Options

command in the Admin menu.

When a password is in effect, the following commands and functions

can be locked from users who do not know the password:

• Edit keywords • Update/purge catalogs

• Edit descriptions • Import catalogs

• Add files to catalogs • Check/Repair catalogs

• Delete files from catalogs
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In addition:

• The Move Original command in the File menu is automatically

unavailable when the “Update/purge catalogs” option is

restricted in the Security Options dialog box.

• The Delete Original command in the File menu is unavailable

when the “Delete files from catalogs” option is restricted in the

Security Options dialog box.

• The “Add references to copied files” option in Copy Originals is

unavailable when the “Add files to catalogs” option is restricted.

Caution: Once a password has been assigned to a catalog, it is
impossible to change security options, including the password
itself, without knowing the password. Choose your passwords
carefully!

Editing keywords and descriptions

Original files can come with keywords and descriptions that

manufacturers have locked in. Search recognizes these keywords and

descriptions and automatically includes them in the cataloged records

of the original files. However, Search also lets users customize records

by adding their own keywords and descriptions.

Search has several options to make customizing keywords quick and

easy. You can use Search’s keyword thesaurus to add a keyword and its

synonyms to a keyword list. You can also have Search divide a record’s

description into key words that it adds to the keyword list. You can

even edit keywords across multiple records.

Note : Italicized keywords are those of the manufacturer and cannot be
edited. Descriptions included by the manufacturer also cannot
be edited.

To edit a keyword

1. In standard or thumbnail view, select the record whose

keywords you want to edit.
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2. Choose Keywords from the Edit menu, or press -Y, or

—double-click the Keywords box in the catalog window.

3. To add a new keyword Enter the new keyword in the field 

below the keyword list, then click 

Add, or press -A.

To delete a keyword Select the keyword from the list, 

then click Delete, or press -D.

To replace a keyword Select the keyword to be replaced, 

enter the new keyword, and then 

click Replace or press -R.

To add a keyword and Enter the keyword, click Add, then

its synonyms click the Synonyms button. Click OK.

Note: At startup, you may be asked to locate the thesaurus. It is placed
in the Search 3.1.1 folder during installation.

To edit keywords across multiple files

1. Select the records whose keywords you want to edit. To select

more than one record, remember to hold down the Command

key to select one record at a time or the Shift key to select a

range of records.

2. Choose Common Keywords from the Edit menu, or press -Y.
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3. To add a new keyword Enter the new keyword, then 

click Add, or press -A.

To delete a keyword Select the keyword from the list, 

then click Delete, or press -D.

To replace a keyword Select the keyword to be replaced, 

enter the new keyword, and then 

click Replace or press -R.

To add a keyword and Enter the keyword, click Add, then

its synonyms click the Synonyms button.

4. Click OK to save changes.

You can add, replace, or delete the keywords that appear in plain text.

To add words from a file’s description to its keywords list

1. Before cataloging the file or files, make sure that the “Get

Keywords from Descriptions” option is checked in the Keywords

preferences dialog box, found under the Edit menu.

2. Add words like “a” or “the” to the Keywords Exclusions file—also

found in Keywords preferences—in order to prevent meaningless

words in the description from being added to keywords lists.

Editing keywords can be restricted with security options. In addition, if

the LockServer software is not running properly on the network while

you are in multiple-user mode, the Keywords command is unavailable.

To edit a description      

1. In standard view or thumbnail view, select the record to be

edited.

2. Choose Description from the Edit menu, or press -D, or

double-click on the Descriptions box.

3. To add a description Enter the description into the 

Supplemental Description box. 

Click OK.
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To delete a description Select text to be deleted, then 

use the Delete key. Click OK.

Edit description dialog box

You can use the Cut, Copy, Paste, Clear, and Select All commands to

edit descriptions text across multiple documents.

Editing descriptions can be limited with security options. In addition, if

the LockServer software is not running properly on the network while

you are in multiple-user mode, the Description command will be

unavailable.

Updating and purging catalogs

Since catalogs contain the records of original files, changes made to the

original files themselves are not always automatically reflected in their

records. In multiple-user environments, original files could be moved,

edited, and deleted from within Search without other users knowing. In

single-user mode, users can lose track of multiple edits. The

Update/Purge Catalog command helps keep catalogs accurate and up-

to-date in situations like these.
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Note: To exclude certain files from being updated, add them to the File
exclusions list created in File Exclusions preferences.

When updating with the Update/Purge Catalog command, Search

compares each catalog record to its original file. If the original file is

different from the record, the record is updated. Original files need to

be mounted to update their catalog records. If Search cannot find the

original file, it assumes no changes and leaves the record as it is. Or,

you can use the “Perform automatic ‘Find It’ on all lost files” option to

have Search look for the original file. If Search locates the original file,

it automatically updates the catalog with the file’s new location.

When purging the catalog, Search looks for each record’s original file. If

the original file is not found because it is either deleted, unmounted, or

moved, Search purges the record from the catalog. To prevent Search

from purging records of unmounted files, click the “Ignore unmounted

volumes” option.

 

Update/purge dialog box

To update catalogs with the Update/Purge Catalog command

1. Open the catalogs to be updated and choose Update/Purge

Catalog from the Admin menu.

2. Click the “Update catalog images” checkbox.

3. Review and specify options:

Click “Automatically” to have Search automatically update each

record.
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Click “Confirm each update” to have Search ask your approval

for each update.

Select “Perform automatic ‘Find It’ on all lost files” to have

Search look for original files it cannot locate at cataloged

locations. The catalog will automatically be updated with the

new location.

Select “Perform update/purge on all open catalogs” to perform

the function on all open catalogs.

4. Click OK.

To purge catalogs with the Update/Purge Catalog command

1. Open the catalogs to be purged and choose Update/Purge

Catalog from the Admin menu.

2. Click the “Purge catalog images” checkbox.

3. Review and select options:

Click “Automatically” to have Search automatically purge the

records of original files that Search cannot find.

Click “Confirm each purge” to have Search ask your approval

for each purge.

Select “Ignore unmounted volumes” so that Search will not

purge those records whose original files are currently not

mounted.

Select “Perform update/purge on all catalogs” if you wish to do so.

4. Click OK.

Note: Find, Update, and Purge are the only commands you are able to
perform on all open catalogs. Other commands are limited to the
active catalog.

Two ways to update
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Catalogs can be updated with either the Update/Purge Catalog

command or the Add Files command. Both update methods do

essentially the same thing; the difference is where the process starts.

With the Update/Purge Catalog command, updating originates from the

catalogs. In other words, Search looks at the catalog record first and

then goes out to find the original file to compare it to. In this way, you

can update all of your catalog records without having to know exactly

where original file changes took place. You are also able to unclutter

your catalogs by purging records of files that no longer exist.

With Update from the Add Files command, updating originates from

folders or volumes that you specify. In this case, Search looks at the

original file first and then returns to the catalog record for the

comparison. This update method is most efficient when you know

exactly which file, folder, or volume you need to update.
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Deleting records

When purging catalogs, Search reviews your catalogs and removes the

records of original files that are not mounted or that no longer exist. If

you want to remove records of original files that still exist, you need to

use the Delete Records command.

To delete records from a catalog

1. Select the records to be deleted.

To select more than one record, hold down the Command key or

the Shift key as you select the records.

2. Choose Delete Records from the Admin menu.

OR

Press - -D.

Note : The Delete Records command only deletes catalog records.
Original files are left intact.

Importing catalogs

To transfer several records from one catalog to another, you can simply

select the records and use the Copy and Paste or Cut and Paste

commands from the Edit menu. But to merge an entire catalog with

another catalog, use the Import Catalog command from the Admin

menu.

To import a catalog

1. Open both the catalog you want to import and the catalog to be

imported into.

The catalog to be imported to must be the active, or frontmost,

catalog.

2. Choose Import Catalog from the Admin menu.

3. In the subsequent dialog box, select the catalog to import and

click OK.
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Search imports the catalog into the active catalog.
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Check/Repair

If Search crashes while modifications are being made and you are not

using the “Full recovery mode” option—as set in General Preferences—

the Check/Repair feature allows you to make some minor repairs to a

catalog that seems to be “acting up.”

You should use the Check/Repair option after re-opening a catalog that

has been “crashed” by a corrupt graphic. Or, if you notice

inconsistencies—like a blank line in a catalog where information should

be—it may be time to try Check/Repair to see if Search can fix it.

While this option does not give you as good a chance at total recovery as

“Full Recovery Mode” does, it may prevent you from having to recreate

an entire catalog.

To Check/Repair a catalog

1. Make sure the catalog you want to check is the active, or

frontmost catalog.

2. Choose Check/Repair from the Admin menu.

A status box is displayed as Search examines the catalog and

makes any minor repairs.

Multiple-user issues

To switch between single-user and multiple-user modes

1. Choose Preferences from the Edit menu, then select General

from the Preferences submenu.

2. In the subsequent dialog box, select Multiple user or Single user

as your Database mode.

3. You must restart Search to switch between multiple-user or

single-user mode.

To use Search in a multiple-user environment, LockServer software—

which was installed into your Search 3.1.1 Folder during the Search

installation process—must be running on any single workstation
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connected to the network. LockServer is a utility that monitors the

simultaneous use of Search catalogs. If the LockServer is being used

incorrectly, one of the following messages will appear when you try to

open a catalog:

• Catalogs will be opened with read-only permission since no
LockServer could be found on the network. Keep in mind,

however, that multiple users can browse, search, and copy

references (read-only functions) more quickly without the

LockServer turned on, so there may be times when you want to

leave it off.

• Catalogs will be opened with read-only permission since more
than one LockServer was found on the network. If this is a

constant problem for you, you can select the “Look for LockServer

in Local Zone only” option in General preferences. You must then

make sure that only one LockServer is running in the local zone.

In multiple-user mode, users at different workstations can browse the

same catalogs, view the same previews, and work with the same

original files simultaneously. However, features and functions that can

alter original files or catalogs are automatically unavailable, with the

exception of the Keywords, Description, Add Files, and Delete Records

commands. These commands can be restricted through the Security

Options command; however, they are automatically unavailable if the

LockServer program is not being used properly.
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What’s available,
what’s not?

The Admin
menu

The Window menu

All commands are available.

The Search menu

All commands are available.

Most commands in the Admin

menu are unavailable to users

working in multiple-user mode,

with the exception of the Add

Files or Delete Records

commands. These commands

can be restricted through

security settings. Users cannot

update or purge catalogs and

import catalogs. Users cannot

change security options or even

enter the password.
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The Edit menu

Under the Edit menu, users can

edit keywords and descriptions if
the Keywords and Description

commands are still available

through the Security Options

command and if the LockServer

program is running properly.

Users can still copy references

for use in other programs, and

they can still customize

workstations in the General

Preferences dialog box.
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The File
menu

Users cannot move or delete

originals. They can, however,

edit, copy, alias, and reveal

originals. Users can open

multiple catalogs and preview

multiple files, and they can still

send references to other

programs.
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Part Four • Catalog Searches

Overview

The hunt for the perfect file can take valuable time away from primary

projects. With Search 3.1.1, you are able to access files you need by

simply requesting them with a search definition.

This section introduces and explains the following functions and

features:

• searching catalogs

• defining searches

• viewing search results: thumbnail and standard views

The accuracy of shared catalogs and original files is maintained in two

ways. If users are in single-user mode, Search’s security options can be

set to limit access to functions that change catalogs or original files. If

users are in multiple-user mode, many of these same functions are

restricted automatically. In this section, functions that can be locked

from users are noted with a “ ” symbol. Functions are dimmed in the

Search program menus when they are unavailable.

More information on security options can be found in “Setting security

options” in Part Three of this manual. For more information on multiple-

user situations, refer to “Multiple-user issues,” also in Part Three.

Note : The original files cataloged for the examples and screen shots in
the “Viewing search results” section of this chapter are from Ad-

Builder® Electronic, an art service product of Multi-Ad Services,
Inc.

Getting started

Catalogs created in Search are visual databases containing records of

original files. Once a catalog has been built, the original files do not
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need to be available, locally or on network servers, to browse or search

their cataloged records. However, if you want to preview or manipulate

the original files or their references, the files do need to be available.

For more specific information on manipulating original files, please see

Part Six, “Using Search Results.”

To start Search and open a catalog

1. Double-click on the Search icon. After the program is launched,

you should probably set preferences before opening or creating

your first catalog. For details on setting preferences, please

refer to “Preferences” in the Reference section of this manual.

Note: At startup, you may be asked to locate the thesaurus. It is placed
in the Search 3.1.1 folder during installation.

Note: If you have set a default catalog, double-clicking on the Search
application icon automatically opens that catalog.

2. Choose Open from the File menu.

3. In the directory dialog box, select the file name of the catalog

you want to open and then click Open. Or, double-click on the

catalog’s file name.

To open additional catalogs, choose Open from the File menu or

press -O. You can have up to 10 catalogs open at once.

To set a default catalog

1. With the Search application running, choose General from the

Preferences submenu under the File menu.

2. In the General preferences dialog box, choose “Open default

catalog” from the “On startup” pop-up menu.

3. From the subsequent directory dialog box, designate the default

catalog by selecting that catalog’s file name and clicking the

Open button. Or, double-click on the catalog’s file name.

To start Search and open a catalog from the Finder
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Double-click on the catalog icon.

OR

⑦ Drag the catalog’s icon onto the Search application icon until both

are highlighted, then release. You can open more than one catalog

at a time with this method when they are in the same folder. Hold

down the Shift key as you select each catalog’s icon and then drag

all of the icons onto the Search icon and release.

Records are displayed in either standard view or thumbnail view.

Please see “Viewing search results” later in this section for information

on the features and options available.

Searching catalogs

Search gives you the option to search one catalog at a time or multiple

catalogs simultaneously. You can also perform “cascade” searches,

where you continue to reduce the number of records retrieved in

subsequent searches by searching only the records found in the

previous search (see the “Search found items only” option on page 64).

Up to four levels of criteria can be used to define each search. Although

complex searches take more time, more specific search definitions give

you more specific search results.

To search catalogs

1. Open the catalog or catalogs you want to search.

2. Choose Find from the Search menu.

3. In the Find Files dialog box, define your search. For specific

instructions, please see “In detail: defining searches,” beginning

on page 60.

4. If you want to search all open catalogs, select the checkbox

beside this option. Otherwise, only the catalog in the active

window is searched.
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5. Click Find.

6. To view the retrieved records in the catalog window, close the

Find Files dialog box or click on the catalog window to make it

the frontmost window.

If you search more than one catalog at a time, the retrieved records will

be displayed in each respective catalog’s window.

Since the catalog window contains only one set of records at a time—the

entire catalog or a specific set of search results—Search provides you

with convenient ways to recall and display the various sets of records.

To retrieve and display the records of the entire catalog

Choose Find All from the Search menu.

OR

Click Find All in the Find Files dialog box.

Note: The Search menu is dimmed when the Find Files dialog box is
the active window.

To retrieve and display the previous search results

Choose Find Previous from the Search menu.

The Find Previous command will only recall the search results that

immediately preceded the ones currently displayed.

By saving search definitions, you can easily access many different sets

of previous search results. A search definition is a set of frequently used

search criteria that you save so you don’t have to type it in every time

you want to use it. For instructions on how to save a search definition,

see page 64.

Once a search definition is saved, it appears in the Search menu along

with a keyboard shortcut that is automatically assigned to it. From this

point, there are three ways to use saved search definitions.
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To retrieve and display prior search results using saved search
definitions

All the catalogs you want to search must be open. However, if the

“Search all open catalogs” checkbox was not selected when the search

definition was originally saved, only the catalog in the active window is

searched when using that definition.

Choose the saved search definition from the Search menu.

The retrieved records are displayed in the catalog window.

OR

Press the saved search definition’s keyboard shortcut, - -n,

with n being the number from 0 to 9 that Search assigns to the

saved definition.

The retrieved records are displayed in the catalog window.

OR

1. Choose Find from the Search menu.

2. In the Find Files dialog box, double-click on the appropriate

definition name in the saved definitions list. The definition is

then displayed as the current search.

To search all open catalogs, click the checkbox beside this

option.

3. Click Find, and the retrieved records are displayed in the

catalog window—or windows if you searched more than one

catalog.
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In detail: defining searches

Saved definitions list Definition name field

File-o-Mat
description
rows

Logical
operator

Modifying
option Instruction field

Record
attribute

          Find files dialog box
Search description rows

Up to four search description rows can be combined to make a search

definition. To activate a dimmed description row, click its checkbox.

Logical

operator Instruction field
Modifying
option

Record
attribute

Logical  operators:  The logical operators in the first pop-up menu are

used to reduce or expand the search domain: and, or, or and not.
Choosing the and operator limits your search because the items found

must match all listed criteria in that description row and the previous

row. Choosing the or operator expands your search because found items

can match the criteria set in that description row or other rows.

Choosing the and not operator allows you to omit specific files from

your found set.
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Record  attributes:  The record attributes by which you search are listed

in the second pop-up menu: keyword, smart keyword, file name, file type,
volume, catalog date, modification date , expiration date, keyword list or
description. If you choose “keyword list,” a dialog is automatically

displayed:

In this dialog, you enter keywords and synonyms that you want to be a

part of your search criteria.  Just type in a keyword, click Add, and then

click the Synonyms button to automatically add the keyword’s synonyms

to the Keywords Search List. Then, click OK to exit the dialog and

include the keyword and its synonyms in your search criteria. Records

with any of the keywords in the list are found.

The “smart keywords” attribute also increases the flexibility and range of

keyword searching. After selecting “smart keywords” from the attribute

pop-up menu, type a  phrase into the instruction field. When you click

Find, Search breaks the phrase into individual words looks for those

words and their synonyms in the records’ keywords lists. Records whose

keywords contain any of the individual words or the synonyms of those

words are found.

Choosing the Descriptions attribute displays a dialog box in which you

enter the description or the part of a description to be searched for.

Modifying options: Depending on the record attribute chosen, it is

modified with one of the following options : matches, begins with, ends
with, contains, is before, or is after.  The following options are included for

use with the record attributes concerning dates: is today and n/a.
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Instruction field: The instruction field completes each search

description row. In it, you generally do one of the following to complete

the description: 1) type in a file name or keyword or at least part of a

file name or keyword; 2) choose a file type or volume from the pop-up

menu; or 3) set the appropriate date.

Search definitions

Instead of having to enter a lengthy search definition each time you

want to use it, you can save a definition that you use often or in

multiple catalogs. Once saved, a definition remains listed in the Find

Files dialog box until you delete it. It is also listed under the Search

menu with a keyboard shortcut that Search assigns to it. See page 60

for details on using a saved search definition.

Saved definitions list Definition name field

To save a search definition

1. Define the search in the Find Files dialog box.

2. Type a name for the new definition in the definition name field.

3. Click Add.

To delete a saved search definition

1. In the saved definitions list in the Find Files dialog box, select

the search definition to be deleted.

2. Click Delete.

“Search found items only” option

Click the checkbox next to this option if you want to search only the

records found in the previous search. In this way, you can perform a

“cascade” search; you continue to narrow the number of potentially

usable files by searching only the records found by the previous search.
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“Search all open catalogs” option

Click this checkbox if you want to search all open catalogs. Otherwise,

only the catalog in the active window is searched. If you plan to save a

search definition for use in searching all open catalogs, make sure this

option is checked when you save the definition.

Viewing search results

Once retrieved, the records in your found list are displayed in thumbnail

view or standard view, depending on which view you choose from the

Window menu. In either view, the records provide comprehensive

information about the original files and the ability to access and

manipulate the files for use in other documents.

In detail: thumbnail view

Thumbnail of an added file type; note 
pathname and application icon 

Thumbnail of a text file
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Thumbnail view allows you to visually browse the records; only the file

name is listed with each one. When you select a particular thumbnail, the

rest of its file information is displayed in the File Information box, the

Description box, and the Keywords box at the top of the view window.

Note: To select multiple thumbnails, hold down the Command key as you
click on each thumbnail. To select a range of thumbnails, hold down
the Shift key as you click on the first thumbnail and then on the last
thumbnail of the range. The file information, keywords, and
descriptions shown are those of the last thumbnail selected.

Features

• Window View Toggle button–displays more thumbnails in the

window by replacing the File Information, Description, and

Keywords boxes with additional thumbnails. It is located directly

above the vertical scroll bar.

• File Information box–displays file information for the selected

thumbnail. The last row of information in this box reports the

status of the selected record’s original file: if it is available at the

cataloged location, if it is not available at the cataloged location,

or if its volume is not mounted.

• Description box–displays manufacturer and user descriptions of

the selected thumbnail. Double-click on this box to bring up the

Edit Description dialog box.

• Keywords box–displays the keywords for the selected thumbnail

and lists the number of catalog records or retrieved records that

share each keyword.

Note : Italicized keywords were specified by the creator of the file and
are locked; you cannot edit or delete them. Keywords added by
users are in plain text and can be edited.

The bit depth—1, 8, 16, or 32—and quality of thumbnails is determined

before cataloging by the options set in Thumbnail preferences and by

the capability of the hardware being used. For more information on

Thumbnail preferences, please see that portion of  the Reference

section.



76       Search  • User’s Guide

If Search cannot create thumbnails for a particular file type when

cataloging—for instance, for a file type that is user-defined and not in

Search’s original list of supported file types—Search displays the file’s

program icon and pathname as its thumbnail. Thumbnails for text files

show the top left corner of the text document.

    Procedures in thumbnail view    

To sort the thumbnails Choose Sort in the Window menu. Then choose the 

attribute to sort by from the submenu.

To select a record Click on its thumbnail.

To preview original files Double-click on the record or select the records and 

choose Show Previews from the File menu.

To display a file’s information Select the record. Then choose File Info from the File 

menu, or press -I.

To edit a keyword list Select the record. Choose Keywords from the Edit menu,

or press -Y, or —double-click on the Keywords box.

To edit common keywords Select the records. Choose Common Keywords from 

across multiple records the Edit menu or press -Y. Enter the keyword(s), 

click Add, then click OK.

To search by a keyword Double-click on any keyword in the Keywords box.

To edit a description Select the record. Choose Description from the Edit menu

or press -D, or double-click on the Description box.

To copy a record’s original file Select the record or records, then choose Copy Original 

from the File menu.

To move a record’s original file Select the record or records, then choose Move Original 

from the File menu.

⑦ To edit a record’s original file Select the record. Then choose Edit Original from the 

File menu or press -Return.

⑦ To transfer and edit a record’s Select the record. Hold down the Option key and 

original file choose Transfer & Edit from the File menu, or press 

- -Return.
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To delete a record’s original file Select the record or records, then choose Delete Original

from the File menu.

⑦ To alias a record’s original file Select the record or records, then choose Alias Original 

from the File menu.

⑦ To reveal a record’s original file Select the record or records, then choose Reveal 

Original from the File menu.

To copy references to the Select the records, then hold down the Option key and 

Clipboard choose Copy References from the Edit menu.

⑦ To send references to another Select the records, choose Send References from the 

application program. File menu, and then designate the receiving location 

and application program.

⑦ To bypass the Send References Select the records. Choose Send References To from 

dialog box when sending the File menu and select the specified location

additional references to an from the submenu displayed.

already specified location.

In detail: standard view

In standard view, records are displayed in textual rows of file

information. When you select a particular record, the original file’s

thumbnail, descriptions, and keywords are displayed in the boxes at the

top of the window.
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Note : To select multiple record rows, hold down the Command key as
you select individual records. To select a range of record rows,
hold down the Shift key as you select the range.

Features

• Window View Toggle button–displays more record rows in the

window by replacing the Thumbnail, Description, and Keywords

boxes. It is located directly above the vertical scroll bar.

• Thumbnail box–displays the thumbnail of the selected record row.

Double-clicking on this box brings up the original file preview.

• Description box–displays manufacturer and user descriptions of

the selected record. Double-click on this box to bring up the Edit

Description dialog box.

• Keywords box–displays the keywords for the selected record row

and lists the number of catalog records or retrieved records that

share each keyword.

Note : Italicized keywords were specified by the creator of the file and
are locked; you cannot edit or delete them. Keywords added by
users are in plain text.

    Procedures in standard view    

To sort the information rows Choose Sort from the Window menu, then choose the 

attribute to sort by from the submenu. Or, double-

click on the column header.

To select a record Click on its information row.

To preview original files Double-click on the thumbnail box. Or, double-click 

on the record. Or, select the records and choose Show 

Previews from the File menu.

To display a file’s information Select the record. Then choose File Info from the File 

menu, or press -I.

To edit a record’s keyword list Select the record. Choose Keywords from the Edit 

menu, or press -Y, or —double-click the Keywords box.
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To edit common keywords Select the records. Choose Common Keywords from 

across multiple records the Edit menu or press -Y. Enter the keyword(s), 

click Add, then click OK.

To search by a keyword Double-click on any keyword in the Keywords box.

To edit a record’s description Select the record. Choose Description from the Edit menu,

or press -D, or double-click on the Descriptions box.

To copy a record’s original file Select the record or records, then choose Copy 

Original from the File menu.

To move a record’s original file Select the record or records, then choose Move Original 

from the File menu.

⑦ To edit a record’s original file Select the record. Then choose Edit Original from the 

File menu, or press -Return.

⑦ To transfer and edit a record’s Select the record. Hold down the Option key and choose

original file Transfer & Edit from the File menu, or press - -Return.

To delete a record’s original file Select the record or records, then choose Delete Original

from the File menu.

⑦ To alias a record’s original file Select the record or records, then choose Alias Original 

from the File menu.

⑦ To reveal  a record’s original file Select the record or records. Choose Reveal Original 

from the File menu.

To copy references to the Select the records, then hold down the Option key 

Clipboard and choose Copy Reference from the Edit menu.

⑦ To send references to other Select the records, choose Send References from the File

application programs menu, then designate the receiving application.

⑦ To bypass the Send References Select the records. Choose Send References To from 

dialog box when sending the File menu, and from the

submenu displayed, additional references to an

select the destination. already specified location

Part Five • Using Drag-and-Drop Features

Search 3.1.1 supports System 7.5’s drag-and-drop features, allowing

you to use drag-and-drop routines to perform some key Search
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functions. You can catalog files by dragging their icons to an open

catalog. You can create copies of original files by dragging records

from Search to the desktop or another volume. You can even place

files into Multi-Ad Creator® 3.8 by dragging the records to an open

Creator ad.

Search’s drag-and-drop features result in either the cataloging of

original files or the copying of original files to new locations.

Note: Drag-and-drop capabilities are also available under System
7.1 with the Macintosh Drag-and-Drop extension added.

To drag a catalog record or desktop icon, you select the item and

then hold down the mouse button as you move an outline of the

item to a new location. As you drag, you see an outline of the item

being dragged.

As you drag items, feedback is provided to let you know when you

can release the mouse button and complete the drag. For instance,

when dragging records to a mounted volume, you drag the records

to the volume’s icon until it becomes highlighted. You can then

release the mouse button to complete the drag-and-drop sequence.

Or, when you drag to a catalog window, the destination area of the

window is highlighted, signaling that you can release the mouse

button to complete the drag and drop.

The destination area becomes highlighted with a gray or colored outline

when the items being dragged will be accepted. Below, the destination

area of Search catalog windows is shown surrounded by a dashed line.

The File Information, Keywords, Descriptions, and Thumbnail boxes are

not part of the destination area.
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Destination 
area

Opening catalogs

To open a catalog

Drag the catalog’s icon onto the Search application icon until both

are highlighted, then release. The catalog is opened.

You can open more than one catalog at a time with this method

when they are in the same folder. Hold down the Shift key as you

select each catalog’s icon and then drag all of the icons onto the

Search icon and release.

Adding records to catalogs

There are two important points to remember when using drag-and-drop

features to add records to catalogs.

First, drag-and-drop sequences are subject to security restrictions. If

the process of adding records to a catalog is restricted through security

options, you will not be able to use drag-and-drop features to do so.

When you try to drag a folder or file icon onto the catalog, the catalog’s

destination area does not become highlighted.
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Second, files are cataloged according to the settings used the last time

records were added to a catalog. So, before you initiate cataloging with

a drag-and-drop sequence, you must make sure the Search preferences

and options that affect cataloging are set the way you want them to be set.

The following preferences and settings need to be considered before

cataloging:

In the preferences dialog boxes

• File Types preferences:  Make sure all of the file types you are

going to catalog are included in the File Types list. If they are not

included, you need to add them here or Search will not catalog them.

If you try to catalog file types not added to the File Types list,

Search displays a dialog box that tells you edit the list of user-

defined file types in the File Types Preferences or edit the list of

user-selected files in the Add Files dialog.

Please see page 31 for information.

Note: The file types listed in the File types preferences dialog box are
those that Search is able  to catalog, not necessarily those it will
catalog. You select the file types that Search will catalog in the Add
Files dialog box. See “In the Add Files dialog box,” on the next
page.

• QuickTime importing preferences:  Check to see if QuickTime

importing is turned on or off. Please see page 36 for more

information on this preference.

• File exclusions preference: If there are any files you do not
want added to the catalog, make sure to add their filenames here

before cataloging. An explanation of this feature is found on page

39 of the Search 3.1.1 User’s Guide.

• Keywords preferences: If you want descriptions, folder names,

and filenames saved as keywords for the original files you are

cataloging, make sure these options are set appropriately. Please

see page 37 for more information.
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• Thumbnail preferences:  In thumbnail preferences, you choose

the bit-depth level of the thumbnails created, whether dithering

should take place, and compression options. Please see page 39

for more information.

Note: Some thumbnails for user-added file types will contain the
original file’s icon and pathname.

In the Add Files dialog box

• Make sure the appropriate add/update method is selected. Please

see page 40 or more information.

• If you are dragging volumes or folders , you must make sure

that the file types you want to catalog are selected in the File

types list in the Add Files dialog box. Please see page 40 for

instructions on selecting file types in the Add Files dialog box.

Only the file types selected here will be cataloged.

If a file type is not available to be selected, you must first add it to

the file types list in the File types preferences. Please see page 31 for

more information on adding file types.

If you are dragging individual files , they will be cataloged

regardless of whether their file types are selected in the File types

list in the Add Files dialog box. However, their file types must be

included in the File types list in the File types preferences dialog

box before they can be cataloged. Please see page 31 for more

information on adding file types to the preferences list.

To create a new catalog and add records

1. At the desktop level, with Search not running, select the icons

of files, volumes, or folders to be added to a new catalog.

2. Drag the icons over the Search icon until all are highlighted, then

release. Search starts up and displays the following dialog box:
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3. Choose New.

4. In the subsequent directory dialog box, specify a name and

location for the new catalog.

5. Click Save. The records of the original files are added to the

catalog.

To add records to an open catalog

1. Open the catalog you want to add records to.

2. Locate the volumes, folders, or individual files that you want

cataloged.

3. Select the icons of the items to be cataloged.

4. Drag the selected icons to the destination area of the catalog.

5. Once the destination area is highlighted, release the mouse

button. Records for the files are added to the catalog.

To copy records from one catalog to another

While you can use Search’s Import Catalog command to combine entire

catalogs, you can add just some records from one catalog to another by

using either the Copy and Paste commands or the following drag-and-

drop sequence.

Warning: User-added keywords and descriptions are lost  when you use the
following drag-and-drop sequence to add records from one catalog
to another. If you do not want to lose user-added keywords and
descriptions, make sure you use the copy and paste commands to
add records from one catalog to another.

1. Open both the catalog you will drag records from and the

catalog you will drag records to. Resize the catalog windows so

you can view both on your screen.

2. Select the records to be copied.
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Hold down the Command key to select more than one record at

once. To select a range of records, hold down the Shift key as

you select the first and then the last record in the range.

Note: You can move 100 records at a time from a Search catalog.

3. Drag the selected records to the catalog you want to add them to.

Note: A record’s original file must be available on a mounted volume
in order to drag the record to a new catalog or the desktop. If a
record’s original file is not available, you will be able to select
the record but it will not drag when you try to do so.

4. Once the destination area of the receiving catalog is highlighted,

release the mouse button. Records of the original files are added

to the catalog.

Copying original files: dragging from a catalog to the desktop

When you drag records from a catalog to the desktop or a mounted

volume, copies of the records’ original files are made and placed at the

new location. You can drag 100 records at a time to the desktop or

another catalog, and records can only be dragged from the active, or

frontmost, catalog.

To drag records from a catalog to the desktop

1. In the open catalog, select the records.

2. Drag the selected records to the desired location and release the

mouse button. If you are dragging the records to another

volume or folder, make sure the icon is highlighted before you

release the mouse button.

Copies of the records’ original files are made to the specified

location.

Note: A record’s original file must be available on a mounted volume
in order to drag the record to a new catalog or the desktop. If a
record’s original file is not available, you will be able to select
the record but it will not drag when you try to do so.
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 Placing files into Multi-Ad Creator® 3.8

With Search, you have always been able to copy or send original file

references directly to Creator’s Files palette and then place the file into

the ad. Now a drag-and-drop sequence allows you to place the file into

Creator by simply dragging the file’s record from Search and dropping

it into an open Creator ad.

To place a file into Multi-Ad Creator 3.8

1. Open the Creator ad in which you want to place the file or files.

2. In the Search 3.1.1 catalog, select the records of the original files

you want to place.

Hold down the Command key as you select records to select

more than one. To select a range of records, hold down the Shift

key as you select the first and then the last record in the range.

3. Drag the selected records to the Creator ad.

Note: Original files must be available on a mounted volume or hard
drive in order to drag their records from Search 3.1.1 and place
them in Creator 3.8. If the original files are not available, you are
unable to drag an outline of those records to Creator’s ad window.

4. Release the mouse button when the destination area of the ad

window becomes highlighted. In a Creator ad window, the

destination area includes the desk area and ad area but not the

title bar, rulers, or scroll bars.

The original files are placed in the ad area.

Creator 3.8 supports a subset of the file types that Search supports. If

you try to drag a file type to Creator that is not supported by Creator,

the ad window will not highlight and accept the file.
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Part Six • Using Search Results

Overview

Once you have identified the records of the original files you want to

work with, Search provides ways to preview and manipulate the

original files.

This section will describe the following functions and features:

• previewing original files in the various graphics, QuickTime, 

text, and sound preview windows

• viewing an original file’s File Info window, which contains 

comprehensive information about the original file

• manipulating original files:

- Copy original

- Move original

- Delete original

- Edit original

- Transfer & Edit original

- Reveal original

- Alias original

• copying or sending original file references to other application 

programs

Original files do not need to be mounted to search catalogs and browse

records. However, original files must be mounted locally or on a file

server in order to preview or manipulate the files. To preview, copy,

move, edit, delete, alias or reveal an original file or copy or send its

references, Search must be able to locate the original file.
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Using the Find It dialog box to locate original files

If Search cannot locate the original file because it has been moved from

its original place or because it is not mounted, the Find It dialog box is

displayed:

Here, you direct Search to the original file or click Find It to have Search

locate it for you. If Search finds the file at another location on a mounted

volume, you simply click Open and the requested command is completed.

If you select the “Update database with new location” checkbox, Search

will update the catalog with the original file’s new location.

If the original file cannot be found, an alert box informs you that the file

is not located on any currently mounted volume. If the file is on an

unmounted CD, floppy disk, or other removable media, you can insert the

medium now and Search will automatically look for the file on the newly

mounted volume. If the original file is on a network volume that isn’t

mounted, you have to cancel the Find It dialog, mount the network

volume, and then re-choose the command you wish to perform.

Using the Look for cataloged files feature to locate original files
that have been moved from their cataloged location
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When an original file is cataloged, the catalog record created for the file

contains a reference that specifies the original file’s name, volume, and

folder location. Search uses this reference to locate the original file when

the file is required to complete a requested command, such as Show

Preview or Send Reference.

You may at times want to move original files from their cataloged

locations—from a CD or file server to your hard drive, for example, so you

can work without access to the CD or server. After you move the files,

however, Search needs to be able to locate them at their new location.

The way you choose to move the original files depends on whether or not

you want the catalog records updated to reflect the new location. If you do
want the records updated, you can move original files using Search's Move

Originals command or the Copy Originals command with the “Add

references to copied files” option selected. Or, you move or copy the

originals from the Finder, not from Search, and then perform a catalog

update or an automatic “Find It” on each record.

However, if you want to be able to move original files but do not want the

catalog altered, you use the “Look for cataloged files” feature.

Note: For information on the Move Originals and Copy Originals
commands, please see pages 88-89. For information on catalog
updates, please refer to pages 47. For information on the “Find It”
feature, please see page 78.

The “Look for cataloged files” feature allows Search to find original files

at new locations without changing any catalog records. You just need to

move the original files into the same folder as the Search 3.1.1 catalog

and select the “Look for cataloged files” checkbox in Search's General

Preferences dialog box:
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Select this checkbox to have File-o-Mat
look for original files in the same folder 
as the Search catalog

Note : For this feature to be available, this option must be checked
when a catalog is opened.

Search looks for original files in all folders located in the same folder as the

Search 3.1.1 catalog. The files are located even if they are placed in

subfolders:

Search looks for original files when you open a catalog. You can cancel

the procedure by pressing -. (Period key), at which point the “Look for

cataloged files” feature is no longer in effect for that catalog, even though

the checkbox is still selected in General Preferences. You then just need

to close and reopen the catalog to reactivate the feature for the catalog.

Note: The amount of time Search requires to locate original files depends
on the number of folders and subfolders it needs to look through.
The fewer number of folders, the faster Search will work.

There are several important factors to remember when using this feature.

First, Search will always look for an original file at its cataloged location
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before looking elsewhere. If the original file is available at the cataloged

location, Search looks no further and uses that file for previews,

references, and any other actions you may perform.

Second, once Search locates an original file at its new location because it is

not available at its cataloged one, Search does not automatically update the

catalog with the new location. Instead, Search treats the original file at the

new location as a completely separate file; you are simply accessing the file

via the record “belonging to” the original file at the cataloged location. Since

Search was not able to find the original file at its cataloged location, any

commands requested—for previews, edits, or references to be copied or

sent—are completed using the file Search found at the new location.

For example, when you place this new file into Multi-Ad Creator—by

copying or sending the reference or by dragging and dropping a record

from the catalog—a link is created between Creator and the new file even

though you use the record of the original file in the original location to

initiate the command.

Note: If you think you might delete the original files from the new
location, save any Creator ads that use them with the “Include
EPS file” option.

Third, if you have two or more files of the same name available, Search will

use whichever one it finds first. This is a concern if the files are not

identical. If you change the original file at the new location and that is the

file you want to use, make sure it is the only file available. Or, save the

changed file under a new name and add it to the catalog.

Finally, if Search is unable to locate original files at either their cataloged

location or in the same folder as the Search 3.1.1 catalog, the “Find It” dialog

box will be displayed when you request a command requiring an unfound

file. This is true in all cases except printing, where Search will print

whatever files it can find and print the message “The file ‘file.name’ could
not be printed because it was not found” for those it cannot find. You can, if

feasible, make sure all of the files are available before you print by trying to

preview them first. If Search cannot find the file, the “Find It” dialog box is

displayed.



92       Search  • User’s Guide

Previewing original files: the preview window

In Search, original files are previewed in one of four types of preview

windows: graphics, text, QuickTime movie, or sound.

To preview a record’s original file from thumbnail view

Double-click on the record’s thumbnail.

OR

Select the record’s thumbnail, then choose Show Preview from

the File menu, or press the Return key.

To preview a record’s original file from standard view

Double-click on the thumbnail in the Thumbnail box.

OR

Double-click on the record.

OR

Select the record, then choose Show Preview from the File

menu, or press the Return key.

To open multiple preview windows

 Select the records and then choose Show Previews from the File

menu, or press the Return key.

Note: Open preview windows are listed under the Window menu.

To close multiple preview windows

Hold down the Option key and choose Close All from the File

menu, or press - -W.

Procedures in a graphics preview window
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Size Pop-up

Menu

Zoom Out Zoom In

Selection

 tool

To select a portion of the image Drag a box around the portion.

To select the whole preview Choose Select All from the Edit menu, or press -A, 

or double-click on the preview.

To deselect the preview or Click once on the preview.

portion of the preview

To move the preview around  in Hold down the Option key and use the grabber hand

the window to slide the preview.

To zoom in on the preview Click on the Zoom In icon, or press -+ to enlarge, or 

press -  and click on the preview with the  

subsequent magnifying glass.

To zoom out on the preview Click on the Zoom Out icon, or press - – (Minus key)

to reduce, or press -  and click on the preview 

with the subsequent demagnifying glass.

To change the view scale Choose the desired size from the size pop-up menu.

To fit the preview in the window Choose “Fit to window” from the size pop-up menu.

To view previews at actual size Choose “Actual size” in the size pop-up menu.
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To copy the preview to the  Choose Copy from the Edit menu, or press -C.

Clipboard as a PICT

Procedures in a text preview window

If you are previewing a text file, you can make the document easier to read by

changing the font or font size in the preview window. You can even do a “Find”

to locate a specific word and/or portion of a document.

To view the file in a larger font Select a larger font size from the size pop-up menu.

size Or, to increase to the next menu size, press -+.

To view the file in a smaller font Select a smaller size from the size pop-up menu.

size Or, to decrease to the next lower menu suze, press

 -– (Minus key).

To add a customized font size to  Select Other in the font size pop-up menu and add

the font size menu the new size.

To remove a customized font size Select “Remove all custom sizes” from the font size

from the font size menu menu.

To view in a different font Choose a different font from the font pop-up menu.

To move the preview around in Hold down the Option key and use the grabber

the window hand to slide the preview.

To search for specific text Click Find, or press -F, and enter the text to be 

searched for in the Find text dialog box. Press -G

to find the next occurrence.
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To search for text in all open text Click Find, or press -F, and enter the text to

preview windows be searched for. Then, select “All files” from the

Search method pop-up menu. Press -G to find again in the

same preview, or -T to find in the next preview window.

( -G will also go to the next file if there are no more

occurrences in the front file.)

To copy text to the Clipboard Choose Copy from the Edit menu, or press -C. 

Note that the “raw” text is copied; no style changes 

are transferred to the Clipboard.

To print the entire text file Choose Print from the File menu. The text is

printed with font and size changes. Only one page of text is

printed, and it is cropped at the right margin.

Procedures in a QuickTime preview window

When QuickTime is available, the standard QuickTime movie preview

is displayed to preview QuickTime movies. You also get this window

when QuickTime importing is turned on—in QuickTime importing

preferences—and you preview file types that QuickTime importers are

able to convert to QuickTime within Search.
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You are able to play the movie continuously or just a portion at a time,

control the sound of the movie, and resize the window. You can also copy

the movie to the Clipboard and paste it elsewhere. It is pasted as either a

PICT or as a movie, depending on the program you paste it in.

Note: Depending on hardware capabilities, you can open and play
more than one QuickTime movie preview at the same time.

Procedures in a Sound preview window

When QuickTime is available and QuickTime importing is turned on,

some sound file preview windows are the standard QuickTime sound

dialog box:

Here, you are able to play the sound continuously or just a portion at a

time. You can also control the volume. You can copy the sound to the

Clipboard as a movie.

If, however, QuickTime is not available and QuickTime importing is

turned off, sound file previews look like the following:

In this dialog box, you can control playback rate and continuity. The

“Loop” option plays the sound continuously. The “Play all” option plays

all the sounds in a suitcase for one preview window. In this type of

sound preview, you can copy the sound to the Clipboard.



Search • User's Guide  97

Note: The number of sound previews you can open and play at the same
time depends upon hardware capabilities.

Previewing original files: the File Info window

In the File Info window, Search provides you with additional

information about the record’s original file: its size, pathname,

keywords, descriptions, thumbnail, and so forth. Also included is

information about fonts used, colors used, and referenced art.

Note: The thumbnail in the File Info window may be more up to date
than the cataloged thumbnail. When you choose File Info, Search
determines whether or not the cataloged thumbnail is up to date
and if not, it creates a new thumbnail directly from the original
file for the File Info window.

To view the File Info window from standard or thumbnail view

Select the record. Choose File Info from the File menu, or

press -I.
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To open multiple File Info windows

 Select the records and then choose File Info from the File menu,

or press -I.

Note: Open File Info windows are listed under the Window menu.

Once opened, you can copy the contents of the File Info window—both

the text and thumbnail PICT—to the Clipboard. You can also print the

contents of the window by choosing Print from the Edit menu. Both the

window’s text and thumbnail PICT are printed.

To close multiple File Info windows

Hold down the Option key and choose Close All from the File

menu. Or, option-click in a close box or press - -W.

Manipulating original files

To manipulate original files, they must be on mounted volumes. Please

review the information about the “Find it” dialog box on page 72 before

proceeding.

Copy original
With the Copy Original command, users can copy an original file and

designate a location for the copy, such as their own hard disk, a floppy

disk, or a folder at a coworker’s workstation. The original file remains

at its original location.

Since the files themselves are not being changed, original files can be

copied regardless of their location, your database mode, or selected

security options. Users can then edit the copies of the original files and,

if they wish, save them as new files. To be able to search for these new

files, however, they must first be added to a catalog.

To copy original files

1. In standard view or thumbnail view, select the records of the

original files to be copied.
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To select multiple records, hold down the Command key as you

select each one. Or, hold down the Shift key to select a range of

records.

2. Choose Copy Originals from the File menu.

3. In the subsequent dialog box, specify the location for the copies.

4. Select the “Add references to copied files” checkbox if you want

Search to add references from the newly copied files to the

catalog.

5. Click the Folder button when it contains the name of the folder

you want to send the copies to. To send the copies to the

Desktop, click the Desktop button and then the Folder button

(which will then be called “Desktop”).

Move original
With the Move Original command, you can move original files to new

locations. You cannot move originals to read-only media, such as CDs,

but you can move original files from those locations; Search leaves the

original file intact on the CD but moves a copy to a new location and

references the copy in the catalog. If original files have been copied onto

a file server or hard drive, they can be relocated from there as well. You

can move an original file:

• from one folder to another in an unlocked disk
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• from any volume to a folder on an unlocked volume

Once moved, original files are deleted from the original locations,

unless they were located on locked or read-only volumes. Search

automatically updates the records of moved files with their new

locations.

Original files cannot be moved in multiple-user mode, and the Move

Original command is dimmed when the “Update/purge catalogs” option

is restricted with security options.

To move original files

1. In standard view or thumbnail view, select the records.

To select multiple records, hold down the Command key or use

the Shift key to select a range of records.

2. Choose Move Originals from the File menu.

3. In the subsequent dialog box, specify the files’ new location.

4. Click Open, or click the Folder button.

Delete original
Deleting original files permanently removes them from folders and

volumes. Original files located on read-only media cannot be deleted,

but if the files have been copied onto a file server or hard drive, they

can be deleted from there. Original files cannot be deleted in multiple-
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user mode, and the Delete Original command is unavailable when the

“Delete files from catalog” option is restricted by security settings.

To delete original files

1. In standard view or thumbnail view, select the records of the

original files to be deleted.

2. Choose Delete Original from the File menu.

3. Search displays an alert box, asking you to verify the delete

request. Click Yes to delete, or click No to cancel.

Warning: Once original files have been deleted with the Delete
Original command, they cannot be recovered!

⑦ Edit original
When you choose Edit Original, Search launches the original application

that created the file—the “file creator” listed in the file information box in

standard or thumbnail view—and opens the file, provided that the original

application is available to use. You can then proceed to edit the original file.

Original files located on read-only media can usually be edited if you open

them from the read-only device, edit them, and then save them to a

different location. You can also copy the files onto a server or hard drive

and edit from there. Original files can be edited in multiple-user or

single-user mode, and the Edit Original command is always available,

even if a password is in effect.

Since the editing is not taking place within Search, catalogs need to be

updated once original files have been edited.

To edit an original file

1. In standard view or thumbnail view, select the record.

2. Choose Edit Original from the File menu, or press -Return.

Search opens the original file in the application that created it.

After editing an original file, you should do an Update/Purge Catalog

command on your catalog, or Force Update from the Add Files dialog.
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Note : Edit Original uses the Finder to find and open the application
that created the original file. If you are using a program like
Apple’s Apple At Ease™ that causes the Finder to be deactivated,
this command will not work

⑦ Transfer & Edit original
This command allows you to open an original file in a specified

application.  For example, if you are working with an EPS file that you

want to edit but you don’t have the application that created it—the “file

creator” that Search lists in the file’s File information box in thumbnail

view—the Transfer & Edit command will let you launch another

application and give it the EPS file to work with.

Original files located on read-only media can usually be edited if you

open them from the read-only device, edit them, and then save them to

a different location. You can also copy the files onto a server or hard

drive and edit from there. Original files can be edited in multiple-user

or single-user mode, and the Transfer & Edit Original command is

always available, even if a password is in effect.

To transfer and edit an original file

1. In standard view or thumbnail view, select the record.

2. Hold down the Option key and choose Transfer & Edit from the

File menu. Or, press - -↵.

3. In the subsequent dialog box, specify the application program to

open. The application chosen must be able to edit the type of file

that you send it.
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Search launches the program and opens the original file within

the program for you to work on.
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⑦ Reveal original
When you choose Reveal Original, Search locates the original file,

opens the folder that contains it, and highlights the file for you within

the folder. This allows direct access to the location of the original file

without having to follow its pathname.

To reveal an original file

1. In standard view or thumbnail view, select the record.

2. Choose Reveal Original from the File menu.

Search opens the folder that contains the original file and 

highlights the file.

⑦ Alias original
Choosing Alias Original creates an alias to an original file and places

the alias in a location that you specify.

To alias an original file

1. In standard view or thumbnail view, select the record.

2. Choose Alias Original from the File menu.

3. In the subsequent dialog box, specify the location for the created

alias.

Using Search with other programs

Original files are transferred to other programs through the following

commands: Copy/Paste, Copy Reference, Send References, and Send

References To. While System 6 users are limited to the Copy/Paste and

Copy Reference methods, System 7 users can use any of these options.

Each record of an original file contains a reference to the original file.

This reference, and not the original file, is placed in or sent to another
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application or workstation. After the reference is placed, the original

file can be accessed from the new application or user environment.

Copy and paste

When viewing the preview of an original file, users can select the entire

preview or just a portion of the preview to copy to the Clipboard.

Graphics images can be pasted into another program as a PICT;

however, for high-resolution transfer, the Copy Reference or Send

References commands should be used. QuickTime movies or sounds are

pasted as movies, PICTs, or sounds, depending on the program they are

being pasted into.

The contents of the Clipboard can be viewed by choosing Show

Clipboard from the Window menu.

Copying References

The Copy Reference command copies original file references into the

Clipboard. From there, they can be placed into other documents. Note

that with each copy to the Clipboard, new contents replace the current

ones.

To copy references to the Clipboard

1. In standard or thumbnail view, select the records of the original

files to be copied.

2. Hold down the Option key and choose Copy Reference from the

Edit menu. Search copies the original file references, not the

records, to the Clipboard.

3. To view the Clipboard, choose Show Clipboard from the Window

menu.

To place Clipboard references into other programs: an example

using Multi-Ad Creator ®

1. In standard or thumbnail view, select the records of the original

files to be copied to the Clipboard.

2. Hold down the option key and choose Copy Reference from the Edit

menu. Search copies the original file references to the Clipboard.
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3. Start Multi-Ad Creator.

If memory limitations prevent you from running Search and

Creator at the same time, you can quit Search and open Creator

without losing the Clipboard contents.

4. In Creator, choose Place from the File menu, or press -I.

5. In the subsequent dialog box, click “Add Search items to files list.”

The references in the Clipboard are added to the Creator Files

palette. In the Files palette, the references—so therefore the

original files—are listed by file name and with their file type icon.

To place Clipboard references into other programs: an example

using QuarkXPress ®

1. Make sure you have placed the “Get Search” QuarkXTension®

from your Search 3.1.1 folder into the same folder as your

QuarkXPress application. The Get Seach extension was placed

into the Search folder during installation.

2. In standard or thumbnail view, select the records of the original

files to be copied to the Clipboard.

3. Hold down the option key and choose Copy Reference from the

Edit menu. Search copies the original file references to the

Clipboard.

4. Start QuarkXPress. If memory limitations prevent you from

running Search and QuarkXPress at the same time, you can

quit Search and open QuarkXPress without losing the

Clipboard contents.

5. Choose Get Search from the QuarkXPress Utilities menu to

place the image.

Note : The procedure for placing copied references varies among
applications, so please refer to the documentation of the
receiving application for specific instructions.
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⑦ Sending References

The Send References command sends references directly to applications

that you specify in the Send References dialog box. The application

must be running in order for it to appear as an option in the dialog box,

and program linking and file sharing must be turned on.

Once you use the Send Reference command, the location you specified

to accept the reference is listed under the Send Reference To command

in the File menu. Use this shortcut command to bypass the Send

References dialog box when sending more references to that location.

To send references

1. Open the application that is to receive the reference. Make sure

the document to receive the reference is the topmost document.

2. In Search, select the records of the original files to be sent.

3. Choose Send References from the File menu, or press -R.

4. In the subsequent dialog box, specify the location and

application to receive the references.

5. Click OK.

To send references to other programs: an example using Multi-
Ad Creator

1. Start Multi-Ad Creator. Or, make sure that the destination

workstation has Creator running and program linking and file

sharing turned on. Also, the original files to be referenced must

be mounted at the target workstation.

2. In Search, specify the original file references to be sent by

selecting their records.

3. Choose Send References from the File menu, or press -R.

4. In the dialog box, specify the Macintosh, the network zone,

and/or the program to receive the references.

5. Click OK, or press Return.
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6. The references will be sent directly to Creator’s Files palette,

where they can be placed into a Creator ad. They are listed by

file name and with their file type icon.

Note : The procedure for sending references may vary among
applications, so you’ll need to refer to the documentation of the
receiving application for specific instructions.

Note : When you send references to another program, make sure that
the document you want to receive the references is the frontmost,
or active, document.

Printing

You can specify a variety of printing options in the Print dialog box. The

top portion of the dialog is the standard Macintosh Print dialog, where

number of copies, page range, paper source, and so forth are specified,

depending on the type of printer selected with the Chooser desk

accessory. Options unique to Search are found in the bottom portion.

Print dialog box

Printing can only be done from the active, or frontmost, catalog. If you

plan to print selected records only, select them before you request the

Print dialog box.
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Search printing options

• Print selected records only Select this checkbox to print only 

selected records. Otherwise, all of the 

current records in the catalog window 

are printed.

• Print headers Select this checkbox to print column 

headers such as file name, file type, 

and so on.

• Print: Text list, Thumbnails Click the appropriate radio button.

or Actual Images File types are listed with thumbnails.

• Size Click the appropriate radio button.

Select Small and the images will print the size of the on-screen

thumbnails. Select Large and the images will print twice the size of the

on-screen thumbnails. Printing at Actual Size means that the original

files will print in their actual size.

Note: If the actual size of an original file is larger than the paper size,
only one page is printed. For instance, graphics images will
print cropped at the page’s edge. Only one page of a text file will
be printed and it, too, will be cropped on the right margin.

Note: When you select the Thumbnail option, file types are listed with
the printed thumbnails.
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Part Seven • Reference

Overview

In this section, we will review the locations and explanations of Search

3.1.1 menus, menu commands, and any resulting dialog boxes and

options.

The menus are covered in the order that they appear on the Search

menu bar, from left to right, with each menu name appearing on a line

by itself. The menu commands are then listed, followed by their

explanations and keyboard shortcuts if they have them.

Menu commands followed by an ellipsis (…) display a dialog box when

selected, and both the dialog boxes and the explanations for the dialog

box options are included here. In this way, every Search menu item’s

location and explanation is fully documented, with the exception of

some commands on the Apple menu. Commands found under this menu

are unique to each user’s system and vary accordingly.

Keyboard shortcuts can also be used to execute menu commands or

dialog box options. If a shortcut exists for a command, it appears to the

right of that command’s name on the menu. For instance, to create a

new  file—or in Search’s case, a new catalog—without pulling down the

File menu and choosing New, most Macintosh programs allow you to

hold down the Command key and press the “N” key. Note that although

the “N” is shown capitalized, the Shift key should not be held down

unless it is specifically requested.

A modifier key is held down in conjunction with another key or a mouse

click in order to change the effect of the key press or mouse click.

Different combinations of modifier keys are used as keyboard shortcuts.

The abbreviations used in this documentation are as follows:
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Command Key

Shift Key

Option Key

Control Key

Return Key ↵

The Apple Menu

About Multi-Ad Search…

Choosing About Multi-Ad Search displays the About Search dialog,

which lists information about the program. Click OK to close the

screen, or click Credits to get more information about the program

authors and Multi-Ad Services, Inc. Click anywhere in the Credits

window to close it.
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The File Menu

 

when holding down the Option key

New  ( -N)

Choosing New creates an empty Search catalog.
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The elements of catalog windows vary according to which view is in

effect: standard view or thumbnail view. If the catalog is in standard

view, its records are viewed as rows of textual file information, and the

boxes at the top of the window contain the thumbnail, keywords, and

description of a selected record.

If the catalog is in thumbnail view, the records are viewed as

thumbnails, and the boxes at the top of the window contain the file

information, keywords and descriptions of the selected record.

Open…  ( -O)

Choosing Open brings up a standard Macintosh file directory dialog

box. You can then locate and open any Search catalog existing on any

mounted volume, such as hard disks, floppy diskettes, or networked

volumes. In Search, you can have up to ten catalogs open at once, and

they can all be searched simultaneously.

Close  ( -W)

Choosing Close causes the active, or frontmost, window to be closed and

removed from the screen, just as if you had clicked on the Close box in

its upper left corner. To close a window that is not active, click it once to

make it active and then choose Close.
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Close All  ( - -W)

Choosing Close All causes all open preview windows or File Info

windows to close. Close All will also close all catalog windows when a

catalog window is the active, or frontmost window.

You must hold down the Option key while viewing the File menu in

order to access this command.

Catalog Info…

Use the Catalog Info command to get general information about the

catalog in the active window. You can choose Print from the File menu

to print the contents of the window or choose Copy from the Edit menu

to copy the contents of the window to the Clipboard.

The information available includes the following:

• Full pathname –the exact location of the catalog from volume

to folder(s) to file name.

• Total keywords –the total number of unique keywords

contained within the catalog’s records.
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• Total files –the number of original file records contained in the

catalog.

• Catalog size –the amount of disk space the catalog occupies.

• Creation date –the date the catalog was created.

• Modification date –the date the last changes to the catalog

were made.

• Current mode– tells whether you are single or multiple-user

mode and whether you can make changes to the catalog (write)

or only browse and search it (read).

• General permissions– lists Search functions that the user can

perform. These functions can be restricted in multiple-user

mode or with security settings when in single-user mode.

• Admin permissions– lists Search functions that the user can

perform. These functions are automatically disabled in

multiple-user mode.

• Keywords box –lists all of the keywords used in the catalog

records.

• Current users box –lists all of the current users of the catalog.

• Volumes box –lists the volume or volumes on which the

original files referenced in the catalog are located.

 ⑦ Send References… ( -R)

Use the Send References command to send references of original files

directly into other programs and documents that you specify in the

following dialog box:
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To send references, begin by starting the receiving application and

opening the receiving document. Return to Search and select the

records of the references you want to send, and then choose Send

References from the File menu. File sharing and program linking must

be turned on to send references between workstations. When using

Creator, the original files to be referenced must be mounted at the

receiving location.

Since references get placed differently in different receiving documents,

you need to refer to the documentation of the receiving application for

specific instructions.

⑦ Send References To

Once you use the Send Reference command, the location you specified

to accept the reference is listed under the Send Reference To command

in the File menu. Use this shortcut command to bypass the Send

References dialog box when sending more references to that location.

File Info…  ( -I)



Search • User's Guide  117

When you select a catalog record and then choose the File Info

command, a window which contains the original file’s information is

displayed.

The following file information is included for all original file types:

• Full pathname –the exact location of the original file.

• File type –the file type of the original file. You can add file

types for Search to recognize in the Preferences dialog.

• File creator –the name of the application in which the original

file was created. You can add applications for Search to

recognize as file creators in the Preferences dialog box.

• Creation Date –the date and time the original file was created.

• Last modification Date– the date the original file was last

modified.

• Expiration date –the expiration date of the original file.

Manufacturers may include an expiration date on art to prevent

outdated logos or slogans from being used in advertisements.
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• Size –the size of the original file.

• Needs updating– tells you if the current record reflects the

original file or if needs to be updated.

• Thumbnail box –shows the thumbnail of the original file.

• Description box –lists all of the manufacturer-provided and

user-defined descriptions for the original file.

• Keywords box –lists all of the manufacturer and user-defined

keywords for the original file.

Other information available in this window varies according to the file

type of the record selected. For instance, additional information for an

EPS file might include the file’s dimensions, its resolution, PostScript

information, lists of process or custom colors used, and compression

information.

Show Previews

Choosing the Show Previews command displays the original file

preview of the record or records selected. The type of preview shown

depends on the type of original file you are previewing.

Note: You can have more than one preview window open at once.

Note : To preview an original file, the volume that contains the original
file must be mounted. In addition, Search will not provide
previews for original files of file types it does not support. Please
refer to “File types preferences” later in this section.
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In a graphics preview window , you can change the view scale by

choosing a different percentage from the pop-up menu in the lower left

corner. You can also zoom in and zoom out on the image by clicking on

the Zoom In and Zoom Out icons.

Size pop-up

menu

Zoom out Zoom in

Selection

 tool

The arrow pointer becomes a crosshair when placed over the actual

preview area of the preview window, and you can drag this selection

tool to select a portion of the image. You can then copy and paste this

portion of the original file into another document. When you use the

Copy command with the original file image or a selected portion, the

image may not be copied and pasted at full resolution. Use Copy or

Send References for full resolution.

In a text file preview window,  you can make the document easier to

read by changing the font or font size in the preview window. You can

even do a “Find” to locate a specific word and/or portion of a document.
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QuickTime movie previews are available when QuickTime is

available. You get the standard QuickTime movie dialog when you

preview QuickTime movies or original files that QuickTime importers

are able to convert to QuickTime within Search:

You are able to play the movie continuously or just a portion at a time,

control the sound of the movie, and resize the window. You can also

copy the movie to the Clipboard and paste it elsewhere. Depending on

what kind of program/document you are pasting into, it is pasted as

either a movie or a PICT.
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Note: You can open and play more than one QuickTime movie preview
at the same time, depending on hardware limitations.

Sound preview files are available when QuickTime is available and

QuickTime importing is turned on in QuickTime preferences, sound file

previews are the standard QuickTime sound dialog box:

Here, you are able to play the sound continuously or just a portion at a

time. You can also control the volume.

If, however, QuickTime importing is turned off, sound file previews look

like the following:

In this dialog box, you can control playback rate and continuity. The

“Play all” option plays all the sounds in a suitcase for one preview

window.

Note: You may be able to open and play up to four sound previews at the
same time, depending on hardware capabilities.

Note: Some types of sounds may use the second type of sound preview
window even if QuickTime importing is available.

If Search cannot find an original file because it has been moved or its

volume is unmounted, the following dialog box is displayed:
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In this dialog box, you can direct Search to original files that have been

moved or click Find It to have Search look for you. If the original file

cannot be found, an alert box will inform you that the file is not

currently mounted on any volume.

If the original file is on an unmounted CD, floppy disk or other

removable media, you can insert the medium now and Search will

automatically look for the file on the newly mounted volume. If the

original file is on a network volume that isn’t mounted, you will have to

cancel this dialog and mount the network volume. When the original

file is found, click the checkbox next to the “Update database with new

location” if you want Search to update the catalog.

The Find It dialog is also used with the Move Original, Copy Original,

Delete Original, Edit Original, Transfer & Edit Original, Alias Original,

Reveal Original, and Send References commands when an original file

cannot be located.

Copy Original…

By selecting records and choosing Copy Originals, you can copy original

files to different locations, such as a different folder on your hard drive
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or a folder on a coworker’s workstation. When you choose the Copy

Original command, the following dialog box is displayed:

You designate where you want the copies to go, and if you are in single-

user mode, you designate whether or not you want Search to add

references to the new file copy.

Move Original…

With the Move Original command, you can move original files to new

locations. You cannot move originals to read-only media, such as CDs,

but you can move an original file from those locations; Search leaves

the original file intact on the CD but moves a copy to a new location and

references the copy in the catalog.

Once the files have been moved with the Move Original command,

Search automatically updates the catalog with their new locations.

Choosing Move Original brings up the following dialog box:
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The Move Original command is not available in multiple-user mode and

can be disabled through security options.

Delete Original…

By using the Delete Original command, you can permanently remove

original files from unlocked folders and volumes, but not from read-only

media such as CDs. To delete an original file, select its catalog record

and choose Delete Original from the File menu. This command is not

available when in multiple-user mode, and it can be disabled through

security options.

Warning: Once original files have been deleted with the Delete 
Original command, they cannot be recovered!

⑦ Edit Original  ( -↵)

When you select a catalog record and then choose Edit Original, Search

tries to launch the original application that created the file and then

opens the file for editing. The application that created the original file

must be available. The Edit Original command is always available in

both single-user and multiple-user mode, even if a password is in effect.

After editing an original file, you should do an Update/Purge command

on your catalog.

Note : Edit Original uses the Finder to find and open the application
that created the original file. If you are using a program like
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Apple’s Apple AtEase™ that causes the Finder to be deactivated,
this command will not work.

⑦ Transfer & Edit Original  ( - -↵)

This command allows you to open an original file in an application

other than the one that created it. For example, if you are working with

an EPS file that you want to edit but you don’t have the application

that created it—the “file creator” that Search lists in its File

information box and File Info window—the Transfer & Edit command

will let you launch another application and give it the EPS file to work

with. You must hold down the Option key while viewing the File menu

in order to access this command.

⑦ Reveal Original

When you choose Reveal Original, Search locates the original file,

opens the folder that contains it, and highlights the file for you within

the folder. This allows you direct access to the location of the original

file without having to follow its pathname.

⑦ Alias Original   

Choosing Alias original creates an alias to an original file. After you

choose Alias Original, Search displays a dialog box in which you specify

a location for the alias.

Page Setup…

Choosing Page Setup opens a dialog box that lists standard Macintosh

page setup options, which vary according to the printer type selected

under the Chooser desk accessory.

Print… ( -P)

Choosing Print opens a dialog box that lists standard Macintosh

printing options, which vary according to the printer type selected

under the Chooser desk accessory. Options unique to Search are found

in the bottom section of the dialog box.
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When a LaserWriter® printer is selected in the Chooser, the Print

dialog box conforms to standard LaserWriter printing conventions.

The following Search options are found in the bottom portion of the

Print dialog box.

• Print selected items only –choose this option to print only the

catalog records you have selected. Otherwise, all the records in

the active catalog window will print.

• Print headers –choose this option to print the column headers

such as file name, file type, and so forth.

• Print Text list , Thumbnails , or Actual images –select how

you want the records to be printed. If you print thumbnails, file

types are listed with the thumbnails in the printout.

• Size –Small, Large, or Actual Size (1 per page)–choose the

printing size for the thumbnails or actual images.

Selecting Small means that the images will print the size of the

on-screen thumbnails. Selecting Large means that images will

print twice the size of the on-screen thumbnails. Printing at

Actual Size means that original files will print in their actual

size.

Note: If the actual size of an original file is larger than the paper size,
the image will print cropped at the paper’s edge.
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Quit  ( -Q)

Choosing Quit causes Search to close all currently open windows and

then itself.

The Edit Menu

while holding down the Option key

Undo  ( -Z)

Choosing Undo lets you undo an action and return to the state that

existed prior to that action. When Undo is not applicable to a certain

action, it is dimmed in the Edit menu.

Cut  ( -X)

When catalog windows are active, choosing Cut removes selected

records from the active catalog and places them in the Clipboard, ready

to be pasted into another catalog. If you were to view the Clipboard, you

would see the pathname for each cut record. You can also cut text in the

Edit Description and Edit Keywords dialog boxes.

To select multiple records for cutting, hold down the Command key to

select one record at a time and the Shift key to select a range of records.

Note: The Clipboard is a temporary storage area for records and can
only hold one set of records at a time. If you perform another cut
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on a different set of records, those records will replace the
records you first cut to the Clipboard.

Copy  ( -C)

When catalog windows are active, the Copy command can duplicate

selected records and move the duplicates to a different catalog, leaving

the original records intact.

You can copy the contents of a catalog’s Catalog Info window or an

original file’s File Info window to the Clipboard.

Previews or portions of previews can be copied to the Clipboard and

pasted into other documents or applications. Graphics previews are

copied as PICTs, QuickTime movies are copied as both a PICT and a

movie. Text is copied as raw text, without any formatting.

The Copy command can also be used to copy text when editing

keywords or descriptions.

Copied items are stored in the Clipboard until they are pasted.

However, if you perform another copy before the current Clipboard

items are pasted, the items will be replaced.

Copy Reference ( - -C)

The Copy Reference command is used to place the original file

references from selected records into the Clipboard. From there, they

can be placed into documents in other applications. The procedure for

placing copied references varies from application to application, so

you’ll need to refer to the documentation of the receiving application for

specific instructions.

You must hold down the Option key while viewing the Edit menu in

order to access this command.

Paste  ( -V)
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Choosing Paste places the current Clipboard contents. Cut or copied

records can be placed into a new catalog. Copied previews or selected

portions of previews can be placed into other documents. Cut or copied

text can be pasted while editing keywords and descriptions.

Note: When you paste, Search copies the information contained in the
Clipboard. Since the information has not been removed from the
Clipboard, you can paste the same data into multiple catalogs or
documents.

Clear

Use the Clear command to delete selected catalog records or selected text.

Keywords… ( -Y)

Use the Keywords command to customize the keywords list in each

catalog record. The following dialog box appears after you select a

record and then choose Keywords from the Edit menu or press -Y:

You can add, replace, or delete the keywords that appear in plain text,

but italicized keywords cannot be edited; they are provided by the

manufacturer and are locked.
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Click the Synonyms button to add the synonyms of the selected

keyword to the list. Don’t forget to click OK to save any changes made

in this dialog. Click cancel to exit the dialog without accepting changes.

Editing keywords is an option that can be limited through security

options. In addition, if Search does not locate LockServer software

launched on the network while you are in multiple-user mode, the

Keywords command will be restricted.

Common Keywords… ( -Y)

Use this command to edit keywords across multiple files. This

command replaces the Keyword command in the Edit menu when

you have two or more records selected. After you choose Common

Keywords, the following dialog box is displayed:

You can add, replace, or delete the keywords that appear in plain text.

Italicized keywords cannot be edited because they are provided by the

manufacturer and are locked.
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Description… ( -D)

You can add your own descriptions to records by choosing Description

and then adding the description in the following dialog box.

Some original files may come with original descriptions that the

manufacturer included, and these descriptions cannot be edited.

However, you can add supplemental descriptions to your catalog

records. Use the Cut, Copy, Paste, Clear, and Select All commands to

edit descriptions text across multiple records.

Editing descriptions is an option that can be limited through the

security options. In addition, if the LockServer software is not running

on the network while you are in multiple-user mode, the Description

command will not be available.

Select All  ( -A)

Use Select All to select all the records in the active catalog or in the

active set of search results. You can then cut or copy the records to

another catalog or copy or send their references. Select All can also be

used in text dialogs, like the Description and Keywords dialog boxes.



132       Search  • User’s Guide

Reduce to Selection ( -T)

This feature allows you to reduce the number of records being viewed

at one time by showing only the selected records. You can then use the

different Find commands under the Search menu to change found

records.

Omit Selection ( - -T)

With this feature, you can reduce the number of records you are

viewing by removing the selected records. You can then use the

different Find commands under the Search menu to change found

records.

You must hold down the Option key while viewing the File menu in

order to access this command.

Preferences

As you choose Preferences from the Edit menu, the following submenu

is displayed:

Choose one of the Preferences categories listed to display its specific

dialog box. In each dialog box, you set a variety of options that

universally affect cataloging and searching.

Preferences are global, meaning that once set, they affect all open

catalogs and all subsequent catalogs you open or create. Preferences



Search • User's Guide  133

settings are saved in the Search 3.1.1 Preferences file in the System

folder.

General Preferences

Choosing General from the Preferences submenu brings up the General

Preferences dialog box. Any user can customize his or her workstation

using General preferences.

• List view columns– By selecting the appropriate checkboxes, you

designate which file information is listed in standard view and

the order in which it is displayed. Use the grabber hand to drag

columns into the order you want them, and adjust the column

widths by clicking on the lines between the columns and dragging

them to the desired width. A dotted line may appear, designating

the right page boundary if you were to print.

• On startup– Choose from the following options:

Do nothing –double-clicking on the Search icon starts the

program and displays the menu bar at the top of the screen.

Open default catalog –choosing this option displays a

directory dialog box where you select the default catalog. The

catalog’s pathname is displayed in the field to the right of the

pop-up menu. You can select a different default by clicking on

this field or by clicking on the “Open default catalog” field when
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“Open default catalog” is selected. When you double-click the

Search icon, Search opens the default catalog.

Do “Open…” command –double-clicking on the Search icon

starts Search and displays a directory dialog box so that you

can choose which catalog to open.

Do “New…” command –double-clicking on the Search icon

starts Search and displays a directory dialog box in which you

can specify a name and location for a new catalog.

• Database mode– Specify whether your workstation will operate

in single-user or multiple-user mode. In a multiple-user

environment, multiple-user mode allows any number of users to

access the same catalogs, previews, and original files

simultaneously. However, to protect a catalog’s accuracy and save

it from unwanted changes, any Search functions that can alter a

catalog are automatically restricted in multiple-user mode.

In single-user mode, you are unable to access catalogs that are

being used by others. However, once a catalog is open, you can

access all Search functions, including those that can change

catalogs, unless security options have been set. Please see

“Setting security options” in Part Three for more information.

To use Search in a multiple-user environment, LockServer

software must be running on any single workstation connected to

the network. This software is a small Search utility that monitors

simultaneous use of a Search datafile. It was placed into your

Search 3.1.1 Folder during the Search installation process.

If the LockServer is being used incorrectly, you will get one of

the following on-screen messages when you try to open a

catalog:

• Catalogs will be opened with read-only permission since no
LockServer could be found on the network. Keep in mind,

however, that multiple users can browse, search, and copy

references (read-only functions) more quickly without the

LockServer turned on, so there may be times when you want

to leave it off.
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• Catalogs will be opened with read-only permission since more
than one LockServer was found on the network. If this is a

constant problem for you, you can select the “Look for

LockServer in Local Zone only” option in General preferences.

You must then make sure that only one LockServer is

running in the local zone.

If you keep getting one of these messages and you shouldn’t

be, please check with your catalog administrator.

Note : You must restart Search after changing between single and
multiple-user modes.

• Use full recovery mode– When Full Recovery is selected, Search

creates a file called catalogname•i to back up a catalog during

any modification process. This file contains a safety image of the

original catalog and is removed upon the successful closure of the

original catalog. While this protection may make the program run

slower, it does make it safer. It is highly recommended that you

take advantage of this feature.

Note :  You must restart Search after changing this setting.

• Look for LockServer on local zone only– When you select this

option, Search saves time by looking for the LockServer in the

local zone only. If Search doesn’t find the LockServer in the local

zone or if it finds more than one, catalogs are opened with read-

only permission; you can only browse and search records.

If you do not have this option selected, Search looks for

LockServer in all zones. This generally takes more time than

looking in the local zone only, and if Search finds LockServer

running on more than one zone, catalogs will be opened with

read-only permission.

• Do Find All search when opening catalog– Leave this

option—which is only available in multiple-user mode—

unselected for quicker work over a network. When this option is

not selected, Search opens catalogs but does not load and

displaying all of the catalog’s records. You can then find and

display only the records you want.
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• Preview colors– If your monitor is only capable of 8-bit (256

colors) color display,  previews can be viewed by using their

Exact color palette or the System palette.

When you choose Exact palette, the frontmost preview is

displayed using its own colors. However, other open preview

windows will share the palette of the active preview window,

which may cause some distortion of colors in the other previews.

In addition, each time you bring a different window to the front,

all of the preview windows are redrawn using the color palette of

the newly activated window.  This can slow you down.

If you choose the System palette, all previews use the same

colors. While color might not be as accurate, you can move from

preview to preview faster because the previews don’t have to be

redrawn each time you select a different preview window.

• Measurement units– Original file dimensions, found in the

File Info window, can be listed in inches, points, picas,

millimeters, and centimeters.

Application Names Preferences

Choose Application Names from the Preferences submenu in the Edit

menu to view the application types that Search identifies as file

creators. You can add applications for Search to identify as original file

creators.
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Application 

type field

Application

description field

Italicized application types are built into Search and cannot be

edited. Additional types are shown in plain text and can be added,

deleted, or replaced using the editing buttons to the right of the

list and the fields below it.

If an application is described as “Unknown” beside its four-letter

application type, it means that Search has not yet identified what

application was used to create the cataloged files that contain the

four-letter application type, or code.

To identify unknown file creators, click Find unknowns. Search

then looks through all currently mounted applications to identify

and list the specific application that belongs with the four-letter

code. Once located, Search replaces “Unknown” with the

appropriate application description. This description is now used

in the File info window and the file information box in Standard

and Thumbnail view to identify file creators.
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File Exclusions Preferences

Choosing File Exclusions from the Preferences submenu displays the

following dialog:

File
exclusions
list

Select the “Use Exclusions File” checkbox when you want Search to

skip the file names in the File exclusions list when adding to or

updating a catalog. To add a file to the File exclusions list, enter its file

name and click Add. Click OK to accept your changes and exit the

dialog box.

Note: To exclude an entire file type, you would deselect that file type in
the Add Files dialog box. Please see “In detail: setting catalog
add/update options” in Part Three for details.

When the “Automatically Add Exclusions” checkbox is selected, files

that “crash” your catalogs during the cataloging process can

automatically be added to the File exclusions file and skipped during

the next cataloging attempt. When you restart after a crash, Search

will ask you if you want to add the corrupt file to the File exclusions

list. While this option slows down the cataloging process, it also saves

you from having to hunt down a corrupt file that’s causing problems.
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File Name Suffixes Preferences

Choosing File Name suffixes from the Preferences submenu displays

the following dialog:

Here, you are able to tell Search to treat all files with a particular suffix

as a specific file type. Options available in the pop-up menu reflect the

list of file types that Search recognizes, including all file types that

Search automatically recognizes or any added by the user.
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File Types Preferences

Choose File Types from the Preferences submenu in the Edit menu to

view the file types that Search can catalog and search by. You can also

add new file types to the list.

File type 

field

File type

description field

When discussing file types, please remember the distinction between file

types Search recognizes (can catalog, search) and those it supports (can

catalog, search, and provide a preview and thumbnail for).  User-added

file types are only recognized by Search—with the exception of file types

that can be converted to QuickTime movies through QuickTime

importers. Thumbnails for user-defined file types consist of their program

icon and pathname. Previewing is not possible unless specific criteria, as

listed on the next page, are met.

Note:  Italicized file types are built into Search and cannot be edited.
User-defined file types are shown in plain text and can be added,
deleted, and replaced using the editing buttons to the right of the
list and the fields below it.
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Search automatically supports the following file types:

    Type       Name   

AIFF Audio IFF (sound file)

AIFC Audio IFF-compressed (sound file)

EPSF EPS

EPSP EPS (PC format)

GIFf GIF

DEWF Instrument (sound file)

PNTG MacPaint

8BIM Photoshop 2.0

8BPS Photoshop 2.5

PICT PICT

RIFF RIFF

SFIL snd Suitcase (sound file)

FSSD SoundEdit (sound file)

jBl SoundEdit Pro (sound file)

sfil System 7 Sound (sound file)

TEXT Text

TIFF TIFF

Search automatically recognizes the following file types, and it will

support them if the criteria in the Special notes are met:

    Type       Name       Special notes   

AdSt Creator System 6 Stationery -preview must be saved with original file

CIF CIF -preview must be saved with original file

JFIF JFIF -requires QuickTime

JPEG JPEG -requires QuickTime

moov Movie -requires QuickTime importing

Moov QuickTime movie -requires QuickTime

MuAd Creator -preview must be saved with original file
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PCDI Photo CD -requires System 6.05, 32-bit color 

QuickDraw, and a 68020 processor or 

 better

PICS PICS -requires QuickTime importing

ALB5 PageMaker 5.0 -preview must be saved with original file

PRS2 Persuasion 2.0 -preview must be saved with original file

StPP JPEG++ -requires QuickTime

trak Audio CD -requires QuickTime importing

Note: The file types supported through QuickTime importing will vary
with the version of QuickTime being used. Additional file types
that come with future versions of QuickTime can be added to the
File types list by clicking the “Add QuickTime Importers” button
in the File Types preferences dialog box.

Since these importers can convert certain file types to QuickTime
movies—a file format that Search automatically recognizes and
supports—these file types can be thumbnailed and previewed by
Search.

Search recognizes the following file types but does not support them:

    Type       Name   

ANPA AP Wire

FHD3 Freehand 3.0

Any user-defined file types

Keywords Preferences

Choosing Keywords from the Preferences submenu displays the

following dialog box:
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In this dialog box, you specify keywords options that affect both

cataloging and record display.

• “Sort keywords” option– Use this option to specify how you

want keywords displayed in the Keywords box in the Thumbnail

or Standard List views—alphabetically or by frequency.

• “Save filenames as keywords” option– To include the name

of each file as a keyword in its catalog record, make sure this

option is selected.

• “Save folder names as keywords” option– To include the

name of the folder containing each file as a keyword, select this

option.

• “Get keywords from descriptions” option– If a record’s

description contains important words that you want included in

the record’s keyword list as well, click the checkbox next to this

option. Search will break a description down into keywords.

• Keyword Exclusions list– When using the “Get keywords

from descriptions” option, you can tell Search to skip words

such as “a” or “the” by adding them to the Keyword Exclusions

list. In this way, you prevent meaningless words in descriptions

from crowding your keywords list.

Photo CD Preferences

Choosing Photo CD from the Preferences submenu under the Edit

menu displays the following dialog:
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Here, you can change the resolution for previews of Photo CD files. As

you increase the resolution, you also increase the amount of memory

needed to display the preview and increase the time it takes to produce

the preview.

QuickTime Importing Preferences

When QuickTime is installed, choosing QuickTime Importing from the

Preferences submenu displays the following dialog box:

QuickTime importing allows Search to support file types it normally

could not by converting certain file types to QuickTime movies—a file

type Search does support. Through this conversion, Search is able to

provide thumbnails, previews, and File Info windows for the file types

the importers can convert.
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• “Do QuickTime importing” option– Click the checkbox next

to this option to activate or deactivate importing.

• Import method– In order to preview the file types listed, they

are converted into movies by the importers. These movies can be

created in files or in memory, depending on the file type. The

information under the “Import methods available” heading
tells whether a file type can be converted into a movie file, a

movie in memory, or both.

From the Import method pop-up menu, specify whether movies

should be created in files or in memory. The following options are

available:

Prefer not create movie files –when this option is selected,

movies are created in memory whenever possible. If the file

type—such as a “trak” file—dictates that movie files must

actually be created, the files will be created in order to preview or

create a thumbnail for the file.

Prefer create movies files– when this option is selected, movies

will be created in files whenever possible. However, if the file type

dictates that movies must be created in memory, memory will be

used to preview or create a thumbnail for the file.

Never create movie files –when this option is selected, movies

will be created in memory only. You will be unable to preview a

file type that requires the creation of movie files for its

conversion.

Always create movie files– when this option is selected, movies

will be created in files only. You will be unable to preview a file

type that requires movies created in memory only for its

conversion to QuickTime.

The selections you make here are affected by hardware

capabilities. If you are limited in terms of memory available but

have ample storage space, you may want to create as many

movie files as possible.



146       Search  • User’s Guide

• Choose movie file location– click this button and in the

subsequent dialog box, specify a location for any movie files that

are created.

• Delete movie files after use– when this option is selected, any

movie files created to preview or produce a thumbnail for an

original file are deleted after you close the preview or after the

thumbnail is created.

Note: Since sound files do not have graphic thumbnails, importers do
not need to be added before cataloging them. If the importers are
not added before previewing sound files, you may get a preview
window other than the standard QuickTime sound preview.

Note: The file types PICT and Text are already supported by Search
and therefore do not require that importers be added either
before cataloging or before previewing. They are listed here
because they are also supported by QuickTime importers.

As future versions of QuickTime become available, you will be able to

take advantage of any additional importers by simply clicking the “Add

QuickTime Importers” button in the File types preferences dialog box.

Note: QuickTime importing has no effect on file types that Search
automatically supports.

Thumbnail Preferences

Choosing Thumbnail from the Preferences submenu displays the

following dialog box:
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When the “Dither black & white thumbnails” option is selected, black-

and-white thumbnails use dot patterns to simulate levels of gray.

Dithering is a slower process, but it displays a more realistic view of

color depth on black-and-white monitors.

From the Thumbnail Types pop-up menu, select thumbnail bit depth

level. This is the depth the thumbnails are stored and displayed at. You

have the following options:

• Select All–creates 1-bit, 8-bit, 16-bit, and 32-bit thumbnails for all

files. 

• Best Depth–automatically creates the best thumbnail possible.

• Best Depth plus 1-bit–creates the best thumbnail possible plus a

1-bit thumbnail, making it possible to view catalogs on machines

with varying display capabilities.

• 1-Bit–creates 1-bit thumbnails in addition to any other bit depth

level selected.

• 8-Bit–creates 8-bit thumbnails in addition to any other bit depth

level selected.

• 16-Bit–creates 16-bit thumbnails in addition to any other bit

depth level selected.

• 32-Bit–creates 32-bit thumbnails in addition to any other bit

depth level selected.

Note: You can select any combination of 1-bit, 8-bit, 16-bit, or 32-bit levels.
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In Search, all thumbnails are compressed and decompressed to save

space. When QuickTime is available, Search takes advantage of its

compression capabilities (see “Thumbnail compression options,” below).

When QuickTime is not available, the compression method used by

Search is not as efficient and results in larger catalogs. Therefore, if

catalog size is an issue and QuickTime is not available, you may need to

limit the number of 16- and 32-bit thumbnails created.

16- and 32- bit thumbnail compression options

These thumbnail compression options are available only when

QuickTime is available. And, while the default settings will work fine in

most situations, users may want to experiment with the different

options as time permits. A word of caution: experiment with these

settings on practice catalogs. Don’t waste your time creating huge

catalogs containing thumbnails that you wish were different once

cataloging is complete!

Note: Unless you are very familiar with QuickTime compression
methods and understand each method’s benefits and limitations,
you will find it best to use the default settings.

Click the Options button and a dialog box like the following is

displayed:
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Compression settings

Compression settings are furnished by Apple and QuickTime. You can

change these options before cataloging different kinds of file types if you

know that a specific method will work better for a specific file type.

However, the default settings will work best in most cases.

Note: The methods listed in the top pop-up menu may vary with
different versions of QuickTime.

Note: The default setting, Photo-JPEG, emphasizes thumbnail quality
over compression speed. This is the best choice in most situations
because JPEG compression is available in most versions of
QuickTime. Therefore, 16- and 32-bit thumbnails compressed
with this option can be compressed and decompressed on
machines with varying versions of QuickTime.

Compression type

Within certain compression settings, there may be different types of

compressors/decompressors. For instance, if there is more than one

compressor/decompressor type available within the JPEG, all of them—

because they are JPEG—would make thumbnail quality a priority over

speed, but one type may be faster than the others while one type may

compress better than the others.
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Select from the following compression types in the Codec pop-up menu:

• Any–arbitrarily chooses a compressor/decompressor type from

among those available.

• Fastest– chooses the compressor/decompressor type that

emphasizes compression speed over thumbnail quality

• Best Fidelity– chooses the compressor/decompressor type that 

emphasizes thumbnail quality over compression speed

• Best compression –chooses the compressor/decompressor type

that emphasizes creating the smallest possible thumbnail over

quality and speed.

Note: Compressor methods may or may not have more than one
compression type available.

The Search Menu

Find...  ( -F)

Catalog searches are invoked, defined, edited, and saved in the

following dialog box:
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Saved Definitions List D ef inition Nam e Field

Searc h
D esc rip tion
Rows

Log ic al
O perator Attribute O ption Instruction Field
Log ic al
O perator Attribute Instruction Field

You set your search criteria in the search description rows. With up to

four levels of search criteria possible, searches can be made as general

or as specific as you’d like.

Each search description is made up of the following information:

• Logical operators –in the pop-up menu, choose from the

logical operators, which are the words and, or, and and not, to
expand or reduce the search domain. For instance, a search

description asking for graphics that have dog or cat as a

keyword would retrieve more records than one that asked for

graphics that have dog and cat as keywords.

With the first search, you would get all records with either dog

or cat as a keyword. With the second search, you would get only

the records that had both dog and cat as keywords.

• Record attribute –select one of the following attributes to

search by from the pop-up menu in each description row:

keyword, smart keyword, file name, file type, volume, cataloged
date, modified date, expiration date, keyword list or description.

The attribute chosen determines the options available in the

rest of the search description.
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• Modifying option– modify the attribute chosen by selecting

one of the following options from the pop-up menu: matches,
begins with, ends with, contains, is before, or is after. The

modifying options available depend on what attribute you are

searching by. For instance, if you are searching by catalog date,

you can modify the request by asking Search to look for a date

that matches, is before, or is after a date you enter in the

instruction field.

• Instruction field –enter specific information about the search

attribute. If you are searching by date, enter the date you want

the search to be based on. When you search by file type, you

choose the specific file type from the pop-up menu.

You can “Search found items only” by clicking the checkbox next to this

option.  In this way, you can perform a “cascade” search; you continue

to narrow the number of potentially usable files by searching only the

records found by the previous search.

A special feature in Search is its ability to search all open catalogs, not

just the catalog in the active window. Simply click the checkbox next to

the “Search all open catalogs” option. Up to 10 catalogs can be open at

once.

Use the Find button to activate a search and the Find All button to

retrieve all the catalog records.

Search descriptions can be saved as Search Definitions. You can save

frequently used search definitions so that you do not have to type them

in each time you want to use them. Once added, a search definition

appears in the search definitions list and is listed in the Find menu

along with the keyboard shortcut that Search automatically assigns to

it. You can then activate the search by choosing the saved definition

from the Find menu or by pressing its keyboard shortcut.

Find All  ( -G)

Use this command to retrieve and display the records of the entire

catalog in the active catalog window.
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Find Previous

Choosing Find Previous retrieves and displays the records of the search

that immediately preceded the search for the records currently

displayed.

Saved Search Definition names  ( - -n)

Choose the name of a saved search definition to activate that search on

the active catalog. Or, you can press the saved definition’s keyboard

shortcut, - -n, with n being the number from 0 to 9 that Search

assigns to the saved definition.
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The Window Menu

Entire catalogs or records retrieved from the catalogs are displayed in

either thumbnail or standard view. You switch between the two views

in the Window menu. In either view, the records provide comprehensive

information about the original files and the ability to access them for

previewing and for using in other documents. For a more detailed

account of working in the view windows, please refer to “Viewing search

results” in Part Four of this user’s guide.

Use Thumbnail View ( -\)

In thumbnail view, you can visually browse the thumbnails of original

files. The window can be resized to view more or fewer thumbnails.
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Thumbnail  of an added file type; 
note pathname and application icon Thumbnail of a text file

Besides displaying original files in rows of thumbnails, the thumbnail

view window contains the following features:

• File Information box –lists the file information of the selected

thumbnail’s original file: its file type, file creator, cataloged

date, and so forth. The last line in the File Information box tells

if your file is available at the cataloged location. You cannot

manipulate or print an original file if it is not mounted.
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• Description box –lists manufacturer and user descriptions of

the selected record. Descriptions added by the manufacturer are

locked and cannot be edited. Double-click on this box to bring

up the Edit Description dialog box.

• Keywords box –lists the selected thumbnail’s keywords, both

those of the manufacturer and those of the user. Italicized

keywords were added by the manufacturer and cannot be

edited. Keywords are listed by frequency or alphabetically,

depending on the option selected in Keywords preferences.

You can search by any keyword in the list by double-clicking on

it. You can bring up the Edit Keywords dialog box by —
double-clicking on the Keywords box.

When you click the Window View Toggle button, located at the top of

the vertical scroll bar, the File Information, Description, and Keywords

boxes are replaced with additional thumbnails. Click once on the toggle

button to change the view window.

Use Standard View  ( -\)

In standard view, records are displayed in rows of textual information,

such as file name, file type, volume, cataloged date, and so forth of their

original files. You can sort the record list by the contents of any of these

columns by clicking on that column’s heading.
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The original file information in the record rows is supplemented by the

following features.

• Thumbnail box –displays the thumbnail of the selected record.

• Description box –lists manufacturer and user descriptions for

the selected record. Descriptions of the manufacturer cannot be

edited. You can edit user-added descriptions by double-clicking

on this box and then entering additional information in the

supplemental description field.

• Keywords box –lists the keywords of the selected record.

Italicized keywords are those of the manufacturer and cannot

be edited. User-added keywords are in plain text. Keywords are

listed alphabetically or by frequency, depending on which

option is chosen in Keywords preferences.

You can search by any keyword in the list by double-clicking on

it. You can edit the keywords in plain text by —double-

clicking on the Keywords box.

When you click the Window View Toggle button, located at the top of

the vertical scroll bar, the Thumbnail, Description, and Keywords boxes

are replaced with additional record rows. Click once on the toggle

button to change the view window.

Sort

Sort records by choosing Sort and then selecting the attribute to sort by

from the submenu that appears as you hold down the mouse and drag it

to the right.

You can sort by any of the following attributes: file name, volume name,

cataloged date, file type, modified date, or expiration date. In the

standard view window, you can also sort the records by the contents of

any column by clicking on the column header.

Show Clipboard

Choosing Show Clipboard displays the contents of the Clipboard. If you

are copying catalog records or copying references, the Clipboard
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contents will be the pathnames of the original files. If you are copying a

preview or a selected portion of a preview, the Clipboard contains the

image. The Clipboard may also contain text copied or cut when editing

keywords or descriptions.

Note: Since the Clipboard is only a temporary storage area, items in
the Clipboard are replaced by any items sent to the Clipboard in
a subsequent command.

Catalog names

Select the active catalog from among multiple open catalogs by choosing

its name from the Window menu. Search also assigns a number from 0

to 9 to open catalogs so that you can move between catalogs by using a

keyboard shortcut.

Preview • Record name

All open preview windows are listed in the Window menu. To make a

preview window the active and frontmost window, choose its name from

the Window menu.

File Info • Record name

All open File Info windows are listed in the Window menu. To make a

specific File Info window the active, frontmost window, choose its name

from the Window menu.
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The Admin Menu

Security Options…

With Search’s Security Options command, you can set varying levels of

security for individual catalogs. Setting security options protects

catalog accuracy when users are in single-user mode because any

command that can be used to change catalog records can be restricted.

When security options are in effect, the Password command becomes

the only command available in the Admin menu. Menu commands

designated as off-limits are then dimmed and cannot be accessed unless

the password is entered. In the following dialog box, you need to

designate which commands users are able to perform.
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Users in single-user mode can be permitted to do the following without

a password:

• Edit keywords

• Edit descriptions

• Add files to catalogs

• Delete files from catalogs—the Delete Original command is

automatically unavailable when this option is not selected.

• Update/purge catalogs—the Move Original command is

automatically unavailable when this option is not selected.

• Import catalogs

• Check/Repair catalogs

Most of these commands are automatically restricted when a

workstation is set to multiple-user mode, which is done in the General

Preferences dialog box. However, if the LockServer program is running

properly, keywords and descriptions can be edited in multiple-user

mode unless they have been restricted under security options. You can

also add files to or delete records from a catalog in multiple-user mode

unless these features are restricted under security options.

Note: You must close and reopen a catalog for security option changes
to take effect.

Password…

This becomes the only option available in the Admin menu when

security options are in effect. To gain access to restricted commands,

choose Password and then enter the password.
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Add Files…( - -A)

Choosing Add Files brings up the following dialog box, where you

specify files, folders, or volumes to be added or updated in your

catalogs. Other add and update options are also set here.

Folder
button

Summary of options selected 
in Thumbnail preferences

List 
box

Add/Update options to be set include the following:

• File types –from the scrolling list, click on the file types to

select or deselect files to be added or updated. Any user-defined

file type you have added in File Type preferences is available

here, along with the built-in selections.

• Include all subfolders –click this checkbox to include all

folders within the folder you want to add to the catalog.

• Update method –choose from the following in the pop-up menu:

Add Only–records of new files are added.

Add & Update–records of new files are added; records from 

changed files are updated.

Update Only–records of changed files are updated.
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Force Update–records of files are updated even if the files 

haven’t been changed.

Delete Records…  ( - -D)

Choosing this command will delete selected records from the active

catalog. Original files, however, are not deleted.

Update/Purge Catalog… ( -U)

Choosing the Update/Purge Catalog command brings up the following

dialog box:

When you update with this command by selecting the “Update catalog

images” checkbox, Search begins with the catalog record and compares

it to the original file. If the original file is different from the record,

Search updates the record.

However, if an original file has been moved or is not mounted, Search

cannot make the comparison and will assume no changes need to be

made to the record (Be careful: if you are running the purge command at

the same time, Search will delete the record.) You can tell Search to

automatically update any record that needs it, or you can request that

each update first be confirmed by you. You can also tell Search to “Ignore

unmounted volumes” when updating. When the “Perform automatic ‘Find

It’ on all lost files” option is selected, Search will try to locate files not

found at their cataloged location. If Search finds the original file, it

automatically updates the catalog with the file’s new location.
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Use the “Purge catalog images” to delete records of original files that no

longer exist. When purging records, Search begins by looking for the

original file. If it cannot be found, Search deletes the record.

As with the update command, you can tell Search to automatically

purge records, or you can request that each purge first be confirmed by

you. You can also tell Search to “Ignore unmounted volumes” when

purging; in this way, records won’t be deleted when Search can’t find

the unmounted volume that contains their original files.

You can perform an update/purge on all open catalogs. However, it is an

option that is unavailable when in multiple-user mode, and it can be

restricted through security options.

Volumes… If you have renamed a volume, use the Volumes command

to update the catalog records with the new name of the volume.

Otherwise, Search will not be able to locate the original files for

previewing or manipulating because it appears that the volume—

because of its new name—is not mounted.

Import Catalog…

Before choosing the Import Catalog command, open both the catalog to

be imported and the catalog to be imported to. The latter should be the

active catalog.
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Check/Repair Catalog

If Search crashes while modifications are being made and you are not

using the “Full recovery mode” option—as set in General Preferences—

this new feature allows you to make some minor repairs to a catalog

that seems to be “acting up.”

If you are not using Full Recovery Mode, you should use the

Check/Repair option after you re-open a catalog that has been “crashed”

by a corrupt graphic. Or, if you notice inconsistencies—like a blank line

in a catalog where information should be—it may be time to try

Check/Repair to see if it can fix it.

While this option does not give you as good a chance at total recovery as

“Full Recovery Mode” does, it may prevent you from having to create an

entire catalog over again.
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Appendix One • AppleScript Commands

Search 3.1.1 supports AppleScript functions. If you are interested in scripting,

please contact your Apple dealer for more information. Specific AppleScripting

documentation is available from Apple.  For more information on the following

AppleScript terms that Search 3.1.1 supports, please open Search as a dictionary

from within Apple’s Script Editor™:

Required Suite
open - Open a catalog
place - Add file references to a catalog
print - Print a catalog
quit - Quit Search
run - Run Search

Search 3.1.1 Suite
addDescription - Add a description to files that are 

in a catalog
addFiles - Add files to a catalog
addKeywords - Add keywords to files that are in a 

catalog
aliasOriginal - Make alias files for files that are in

a catalog
autoUpdatePurge - Update/purge a catalog
chooseWindow - Move a window to the front
clear - Remove the selected objects
closeWindow - Close a window
copy - Copy the selected objects onto the Clipboard
copyOriginal - Copy original files that are in a 

catalog
countFilesFound - Return the number of files that are 

found in a catalog
countFilesInCatalog - Return the number of files in a 

catalog
countFilesSelected - Return the number of files that 

are selected in a catalog
cut - Move the selected objects to the Clipboard
deleteOriginal - Delete original files that are in a 

catalog
editOriginal - Edit original files that are in a 

catalog
find - Find files in a catalog
findAll - Find all files in a catalog
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findByDefinition - Perform a pre-defined search on a 
catalog

findPrevious - Perform the previous search on a 
catalog

getCatalogKeywords - Return a list of unique keywords 
for a catalog

getCatalogUsers - Return a list of current users for a
catalog

getCatalogVolumes - Return a list of volume names for 
a catalog

getFileAlias - Return aliases to files in a catalog
getFileCatDate - Return the cataloged dates of files 

in a catalog
getFileCreator - Return the file creator types of 

files in a catalog
getFileDescription - Return descriptions of files in a

catalog
getFileExpDate - Return the expiration dates of files 

in a catalog
getFileIndex - Return indexes of files in a catalog
getFileKeywordList - Return the keyword list of a file

in a catalog
getFileModDate - Return the last modification dates of

files in a catalog
getFileType Srch - Return the file types of files in a

catalog
getFileVolumeName - Return the volume names for files 

in a catalog
moveOriginal - Move original files in a catalog
newCatalog - Create and open a new catalog
omitSelection - “Finds” all unselected records
paste - Paste objects from the Clipboard
printFrontWindow - Print a window
reduceToSelection - “Finds” all selected items
repair - Repair a catalog
revealOriginal - Reveal the files in a catalog
selectAll - Select all objects
selectFileAliases - Select files in a catalog by alias
selectFileIndeces - Select files in a catalog by index
selectFileNames - Select files in a catalog by name
sendReference - Send file references to an application
showCatInfo - Display the Catalog Information window 

for a catalog
showFileInfo - Display Get Information windows for 

files in a catalog
showPreview - Display Preview windows for files in a 

catalog
sortCatalog - Sort the files in a catalog
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Appendix Two • File Types List

The important distinction to remember when discussing file types is between Search’s

ability to recognize a file type and its ability to support a file type. When Search

recognizes a file type, it can catalog that file type. When Search supports a file type, it

can catalog that file type as well as provide a thumbnail and preview for it.

Search recognizes user-defined file types—with the exception of file types that can be

converted to QuickTime movies through QuickTime importers. Search supports these file

types because they are converted to QuickTime Movies, a file type that Search

automatically supports.

Search automatically supports  the following file types:

    Type       Name   

AIFF Audio IFF (sound file)

AIFC Audio IFF-compressed (sound file)

EPSF EPS

EPSP EPS (PC format)

GIFf GIF

DEWF Instrument (sound file)

JFIF JFIF 

JPEG JPEG

StPP JPEG++

PNTG MacPaint

PCDI Photo CD

8BIM Photoshop 2.0

8BPS Photoshop 2.5

PICT PICT

RIFF RIFF

SFIL snd Suitcase (sound file)

FSSD SoundEdit (sound file)

jB1 SoundEdit Pro/16 (sound file)

sfil System 7 Sound (sound file)

TEXT Text

TIFF TIFF



168       Search  • User’s Guide

Search automatically recognizes  the following file types, and it will support
them if the special conditions are met:

    Type       Name       Special Conditions   

AdSt Creator System 6 Stationery -preview must be saved with 

 original file

ANPA AP Wire -preview must be saved with 

 original file

CIF CIF -preview must be saved with 

 original file

FHD3 FreeHand 3 -preview must be saved with 

 original file

AGD1 FreeHand 4 -preview must be saved with 

 original file

moov QuickTime movie interchange -requires QuickTime importing

MOV QuickTime movie interchange -requires QuickTime importing

MooV QuickTime movie -requires QuickTime

MuAd Creator -preview must be saved with 

 original file

Midi MIDI -requires QuickTime importing

MPG MPEG -requires QuickTime importing

PICS PICS -requires QuickTime importing

ALB5 PageMaker 5.0 -preview must be saved with 

 original file

PRS2 Persuasion 2.0 -preview must be saved with 

 original file

XDOC QuarkXPress -preview must be saved with 

 original file

trak Audio CD -requires QuickTime importing

Note:  The file types supported through QuickTime importing will vary with the version of
QuickTime being used. Additional file types that come with future versions of QuickTime
can be added to the File types list by clicking the “Add QuickTime Importers” button in the
File Types preferences dialog box.

Search recognizes  any user-defined file types but does not support them.
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Note: Thumbnails for user-defined file types usually contain the
original file’s icon and pathname.


